Electron - long blue LED when entering particle identify

I’m having an issue with a brand new Electron that I believe is running 0.6.0. When I type particle identify the LED is staying solid on for several seconds and then the terminal session says “! serial: Serial timed out”.

I’ve not seen this phenomenon on any other Electron. Thoughts?

What happens if you try to put it in Listening mode again?

Have tried multiple times with the same result. After it’s on for the “long” period, it goes black for a while and then starts blinking blue, again. Very strange.

Definitely seen it before but more importantly, did you managed to get it working?

I tried it this morning with both an Electron and a Photon without issue. However, when I first tried to do a particle identify I got a message that there was a newer version of the CLI so I ran sudo npm install -g particle-cli and did not see the problem.

Note – I did update my Mac’s Xcode yesterday and wonder if that could have caused the issue. I’ll have my friend update his CLI and see if the problem persists.

Question…if a device (in this case, an Electron) is in listening mode, is the application code running? I’ve always “assumed” (yes, bad idea) that when a device is in listening mode, the application code is not running.

If you are running SYSTEM_THREAD(ENABLED) the application thread will keep running otherwise not, hence for example this statement in the docs

@ScruffR, thanks for the clarification. I’m still trying to understand the basis for the strange LED behavior on my friend’s Electrons. Both are at 0.6.1. I performed the same steps on both an Electron and a Photon in my office this morning and they both behaved the same as always. His application code does put the Electron to sleep for six hours shortly after it starts up and I merely wondered if the listening mode could be impacted. Thanks!