Stuck in Listening mode when compiled with Particle Dev

I ran into a strange problem with my Electron.

I wrote a simple app about a month ago, which prints out some serial data.
However, when I compile the exact same code today and flash the Electron, it gets stuck in Listening Mode after a few seconds.
When I upload the compiled .bin from a month ago (I kept a backup) it works just fine.
Inserting a SIM card and removing the


doesn’t solve the problem.

Is there anything I am missing, or was something changed in the particle offline IDE I missed?

Thank you!

edit: I just tried the same thing with the blink_LED sample. compiling with the online IDE and downloading the firmware .bin works just fine, but doing the same thing with the Particle DEV results in the electron going straight into Listening mode.

Are you sure it’s Listening Mode (blinking blue) and not Safe Mode (breathing magenta)?

Yes it’s Listening mode, blinking blue.

This is the code, works just fine on the Web IDE, but goes into listening mode when compiled with particle DEV.

#include "Particle.h"

void setup(){

void loop(){
  Serial.println("Hello World!");

It’s in a separate folder with only the main.ino and particle.ignore

any idea? I still have the same problem with particle DEV

Can you try STARTUP(

And add some error into your code, to make sure Dev actually building that project you are working on.
If it still builds you’re working on the wrong project.

Thank you! Tried both, still the same unfortunately. Also tried compiling with CLI, same result.

What system version have you got on your Electron, so that I can try with the same setup.

running the latest system firmware.
I just removed and re-added the electron from my devices and it works now? I have no idea why, I didn’t change a thing except removing and re-adding. Thanks for you help !!