Can't get Electron into listening mode

I was able to execute particle flash --serial electron_xxx.bin after pressing the mode button down for three seconds for the past couple weeks but it’s no longer working. Now when I press the mode button down for three seconds or longer, the LED never starts to flash blue like it used to. It just keeps breathing white which is likely a remnant of old firmware that had a; call. If I try to do particle flash --serial electron_xxx.bin now (without the blue light flashing), it (unsurprisingly) gives me this message:
! serial: Error writing firmware...Timed out waiting for initial response from device undefined

I’ve also tried mode COM10 14400 which gets the LED flashing yellow and then I can do a particle flash --usb electron_xxx.bin but the script isn’t working and I can’t tell if it’s a serial/USB connectivity problem or something else.

I’m working in a lab that has poor cellular connectivity for initial testing, hence the; call but I thought I could test other parts of the firmware in here as I’ve been doing for a couple weeks without needing cellular connectivity.

Any suggestions for getting my blinking blue LED back? Thanks!

You can try to get into Safe Mode first and the enter Listening Mode from there
or you go with DFU Mode and particle flash --usb <binfile.bin> which is also the better choice if you happen to fail getting your firmware to stick as it is more verbose about possible issues.
or you try mode COM10 28800

BTW, what exactly does this mean?

any error message to share?


I am having a similar problem with no listening mode, so I tried to use the DFU mode - flashing yellow. Then I ran the command shown here. It gave me the following error.

I can’t find reference to errno:-4048 or EPREM. Do you have any suggestions?

@davidj2525, are you trying to flash via OTA, USB or serial? You have not specified any of these.

Double check your syntax :wink:

1 Like

Thanks, @ScruffR.

I’ve been banging my head against the wall for the past couple days just to get some repeatable issues to report. It seems that the problem with not being able to get into listening mode has to do with the firmware I was trying to upload. If I upload other firmware using either --usb or --serial, I can get it back into listening mode. So I still have to dig deeply into my firmware to figure out why (1) it’s not doing what I want it to and (2) why it won’t allow listening mode from holding down the mode button.

I’m trying to use a UBlox M8Q chip (but not AssetTracker2) by using the AssetTracker2’s UBloxM8Q_GPS library but not having much luck but I’d say the Listening Mode issue is mostly solved at least.

1 Like

Thanks, guys. It looks like @scruff was right I got a successful flash.