Cannot enter Listening Mode using Particle Electron

I have a new Particle Electron. It was working fine for several days. Then I noticed it couldn’t be Flashed using the Web IDE. The Particle Electron is still breathing Cyan, however when flashing I get a time out message and the Particle Electron status doesn’t change at all. Using the web based console I checked the Particle Electron using the Diagnostics tool. It shows that there is an error with Device Vitals.

I connected the Particle Electron via USB to my Mac and entered DFU mode (blinking yellow) and then entered ./particle update (which worked).

However when I tried to enter the Listening Mode (blue flashing light) by holding down the Mode button for 3 seconds - nothing happens - the Particle Electron continues to breath in Cyan.

Any help would be appreciated. Thanks

You can try Safe Listening Mode (first engage Safe Mode and from there press/hold SETUP 3+ sec).

Also, are you using a 3rd party SIM?

Once in LM you could run particle serial inspect and post the output here.

Thanks for helping. I managed to get into Safe Listening Mode and run ./particle serial inspect. I’ll post the result. I am in Australia and am using the SIM card provided as part of the Particle Electron Kit. No modifications.

I also checked to see if I could Flash using the Web IDE again this morning with no luck.

I was wondering - if I can get to Safe Listening Mode if its worth updating any of the firmware?

It is possible for user application code to cause blocking behavior such that the buttons are not recognized.

If you suspect this may be the case, try flashing Tinker onto the device while in DFU mode, then go ahead and let the device restart. Once restarted, see if you can put it into listening mode at that point.

Thanks to everyone. I tried the flash Tinker while in DFU mode as per the previous posting. I’ve included my commands from the Mac Terminal. It seems to be working now - perfectly. Flash works and Diagnostics gives a clean bill of health. To confirm I even flashed a LED_blink_test just to see if it worked without Tinker.

This device has great potential.

During the time I spent trying to figure out the problem I also must have upgraded the firmware. I am now on System Firmware v0.8.0-rc.7. I’m not sure if I should go back to firmware 0.7.0?

IN any case, thanks for all your help.

Sorry I meant to post the Terminal output. Here it is.