Electron won't connect to GSM and unable to put in program mode

Won’t connect to GSM network.

Fast flashing LIGHT BLUE then one RED flash then slow LIGHT BLUE, FAST LIGHT BLUE, Cycle forever.

Won’t go into program mode.

Flashes Pink, Yellow, Fast Green.

Did get a response from ‘particle serial identify’ but now error Serial timed out and I cant remember what mode it has to be in for this.

Particle serial monitor connects but tried a program with SYSTEM_MODE(SEMI_AUTOMATIC); to blink LED and output serial txt but it doesn’t appear to run.

I can occasionally get the blue led on after pressing buttons in different patterns.

Particle doctor works ok for all steps but even after this still same problem.

Particle update works but still same problem after.

Won’t connect or go into program BLUE LED mode.

Have discovered can get into program mode by powering up holding mode button only.

In that mode it responds to particle serial identify and I get the id, IMEI, ICCID and firmware version 1.0.1

Just powered up and flashed white, green then went solid blue then sequence started again this time all the way to fast flashing light blue trying to connect….

Any ideas?

That would be Listening Mode (blinking blue)

What is “program mode”?

I know

  • Application mode cloud connected (breathing cyan - we don’t use “blue” for that to distinguish from Listening Mode)
  • Application mode radio connected (breathing green)
  • Application mode unconnected (breathing blue)
  • Application mode radio module off (breathing white)
  • Safe Mode (breathing magenta)
  • Listening Mode (blinking blue)
  • DFU Mode (blinking yellow)

Additionally to these there are multiple error patterns not tied to any particular mode.

Would be good if you could post a video of that pattern

Sorry for colour and mode description confusion, their are so many.
By program mode I mean listening mode, the one where you upload programs.
I can’t get it to go blue at all now.

Here is video of it never connecting…
https://youtu.be/Zp-Dlley0i0

And here is video of not be able to put in listening mode (blinking blue)
https://youtu.be/eyBE-y5okRQ

Thanks for your help

You can also upload programs in DFU Mode (my personal preference - you should try that via particle flash --usb <yourFirmware.bin> -v).
And also OTA (obviously not an option when you cannot connect to the cloud).

In your first video I can see you have no LiPo connected to your Electron. Try attaching a charged battery and see what happens.
During connection the radio demands more power than your USB port may be delivering.

The fact that your external LED comes on at the very moment you also see the RGB LED flash red should have told you something :wink:
You need to have a current limiting resistor for your external LED. Not only will the LED deprive the radio module from desperately needed current (esp. when being underpowered to start with), but more importantly GPIOs can only sink/drive 25mA max but an unlimited LED may well exceed that. This will not only interfere with the radio connection but may also damage the GPIO or even the controller itself.

For your second video, that is not how you’d engage Listening Mode.
LM is entered by press/holding the SETUP/MODE button after the device got powered up or reset. Not tapping reset while holding SETUP/MODE.

1 Like

Yes I kinda knew that someone would mention the LED, It makes no difference if its in circuit or not, it still wont connect or get it to flash blue, listening mode.
I tried to load a program in DFU mode, it appears to program OK and resets but the program doesn’t appear to run.
I thought DFU mode was for firmware updates not program loading.
It was a test program to flash an LED and output serial, hence the LED being connected in the video. I tried it with the correct resistor and still does not appear to run.
I used SYSTEM_MODE(SEMI_AUTOMATIC); so as I understand it should run even if it doesn’t connect.

Following tips from another thread I deleted my devices in the WEB IDE so now my question is when program is compiled and downloaded how does it know for what firmware version to compile for? Could this be my problem?

Note I am not new to particle electron, this is my original device that got bricked updating firmware, I was using a new device that contained my original particle sim and all was OK till i damaged it removing from breadboard so i went back to trying to use the original device that i managed to reload firmware to and unbrick but it never once connected.
Could the SIM swap about have been a problem?
I did try my phone sim but it didn’t connect.

Also regarding putting in listening mode… i know the format, it may just look odd in the video, you say power up and do it, but that’s not possible with battery connected will be same as pressing both buttons and releasing reset while still holding mode.

Having battery connected BTW also made no difference.
Can I send it to you?

I’m now going to get a SIM800C unit, hoping it will be less trouble.

Your “program” is also a firmware module.

Removing the device (aka unclaiming) from your account 99% of times doesn’t help but may rather cause more issues.

This is one of the problems if you don’t have any other devices of the same kind to build for, then Web IDE will default to the Spark Core as target.

Nope, you can swap SIMs (as long the SIM used is an active Particle SIM - 3rd party SIMs need special treatment in application firmware).

Uhm no. I said

With the LiPo installed, the “or” part applies. You have the device powered, you first tap the RESET button (without holding SETUP/MODE) then when the LED starts blinking, you press/hold SETUP/MODE to enter Listening Mode.
You can also try Safe Mode (don’t need to wait for it to reach magenta breathing) and once you engaged that press/hold SETUP/MODE again till it gets into Listening Mode (that’s called Safe Listening Mode). Once you get into LM run particle serial inspect and post the output here.

Furthermore I’d try these steps

(with CLI 1.40.0 and all in DFU Mode)

particle update
particle flash --usb tinker -v
particle keys doctor <yourDeviceID>
particle keys server

Test again with installed LiPo
If nothing changed flash this debug firmware and see (and post) the USB serial log

Not sure what version of CLI I had so ran
Particle update-cli
Got error saying use
npm install -g particle-cli
It updated I think with lots of depreciated errors

With battery connected, I tap reset only, led goes white then flashes blue so I then press and hold mode and it went flashing blue, listening mode.
Except I can’t program it now as I have no devices in the control panel so I cant select device type or firmware version to compile for.
Can I do that from command line?

In DFU mode (flashing yellow)
Particle update success
Particle flash –usb tinker -v success
I then did particle identify in listening mode to get device id
Particle keys doctor myid
Get error saying make sue in DFU mode but it is and showing in device manager as electron DFU
I then without changing modes did particle flash –usb tinker -v again to confirm it was in DFU mode and it flashed ok

So i’m stuck running keys doctor as it reports not in DFU mode.

Note that running particle keys doctor not in dfu mode gives different error (unable to detect device in DFU mode but when actually in DFU mode particle keys doctor myid gives error in red…

Make sure device in dfu mode, and computer online (both are true) error creating keys.

It also says openssl is not recognised as internal or external command.

I also tried the cloud debug, it flashed ok and serila monitor open ok in dos and arduino IDE but there isn’t any output.

It still not connecting, flashing magenta fast continuously.

If you are using Windows, you should remove CLI via npm uninstall -g particle-cli and if present also via Control Panel - Add/Remove Programs and Features.

After that reinstall via
https://binaries.particle.io/cli/installer/windows/ParticleCLISetup.exe
Also make sure to tick the “remove existing drivers” and “install drivers” checkboxes.

After that check the version via particle --version.
Also check whether the device appears in DevMgr in the correct category in respect to the device mode (DFU, Listening, Safe, Standard).

additionally, after install of particleclisetup.exe if you have some usb errors this thread might help.


there was an issue last week and it may have not been fixed, or may have not affected your machine. just fyi, in case it does.

ScruffR and Bryan,

I am seeing the same symptoms Bryan is(video on April 4) but am not having any luck. Do we perhaps have our boards in a wacky mode that just needs to be reset and re uploaded firmware? I am hoping I don’t have to uninstall the -g particle-cli interface if possible. What are your thoughts?
Thx
MP