Not Able To Flash Electron


#1

So i followed the device setup instructions for the electron and when i installed node.js and installed the particle cli i plugged in my electron and it started to breathe white which i believe is normal. what im not sure about is that it started to rapidly flash red from another led, the red flashing went on for the duration of it being powered, after a while the white led turned flashing blue which i believe is also normal. i have the required firmware.bin file on my desktop so i typed this command in cmd particle flash --serial firmware.bin i hit enter but it seemed to do nothing, i let it run for 20 mins but it still did nothing, the blue led was still flashing and the red led was still rapidly flashing.

Any help is appriciated!


#2

This indicates that the cellular modem is off, probably SYSTEM_MODE(MANUAL) or SYSTEM_MODE(SEMI_AUTOMATIC).

Was the device in Listening Mode (blinking blue), when you did this?

You can also try DFU Mode (blinking yellow) and flash via particle flash --usb firmware.bin -v. This usually gives better feedback about the actual flashing process and potential issues.

You can also put the device in Safe Mode (breathing magenta) and try to flash OTA.

What OS are you running on your host computer?


#3

im using windows 10, this is the first time using the electron so i really dont know how to enter dfu mode or safe mode although it was blinking blue when i tried this

thanks


#4

Did you install CLI via the Windows installer and also install the DFU drivers?
What does particle --version give you?
Does the device show in Device Manager (DFU Mode and Listening Mode)?


#5

i installed CLI via cmd after i had installed node.js, i didnt install any DFU drivers.
particle --version gives me 1.37.0.
in device manager it is only seen under usb ports on COM2


#6

@ascii

Just a sanity check to make sure your device is actually in serial mode when you are trying to flash, can you try:

  1. Connect your electron via USB to your computer
  2. Press the ‘RESET’ button (should see go back to breathing white)
  3. Press and Hold the ‘SETUP’ button for at least 10 seconds (should see start blinking blue)
  4. Run the command particle identify and let us know if that provides the device id and sim id and firmware version.
  5. Then Run the command particle flash --serial firmware.bin

If particle identify works but not the firmware, that may indicate that there is something weird with the firmware or flashing process. If it doesn’t work then that indicates there is an issue with your device, your USB cable, or the installation of the particle-cli


#7

particle identify doesnt work, i dont have a setup button so i instead held the Mode button for around 10 seconds i kept holding the Mode button whilst running the command as if i let go it would go back to slow blue blinking. here is a vid of what im doing. Is it normal for the red led at the top to blink rapidly? firmware.bat is located in sys32 folder.


#8

The solid blue color indicates that the device has crashed and stopped updating the LED most of the time.

You should not be continuing to hold the Mode button. Slow blue blinking (a couple times a second) is the correct behavior. The reason I wanted you to try it with the button is because sometimes that same pattern can happen with other causes and I want to isolate the variables.

Try particle identify again but having let go of the mode button with it blinking blue slowly.


#9

i tried that, it gave me this,

Your device id is 28001f001951353339373130
Your IMEI is 352253065020934
Your system firmware version is 0.4.8-rc.7

i had to run it with cmd as administrator because it wouldnt recognize particle as a command otherwise


#10

Alright, thats a good sign! Sometimes serial mode isn’t very good on older system firmwares, so let’s start by updating the devices system firmware. We’ll need to use DFU mode here, but you shouldn’t need to install anything else if I’m not mistaken.

Run all commands as administrator to be safe.

Run: particle update and follow the instructions it gives you to put your device into DFU mode . (you’ll need to run it again once it’s blinking yellow).

After it updates, put it into DFU mode again with the button combination above.

then run particle flash --usb firmware.bin.

At this point your device should work pretty consistently with both DFU and serial operations.


#11

Actually, DON’T run particle update since you are running such an or firmware version. You will need to first update to version 5.5, then 7.0 then on to version 1.0.0. I believe there are instructions for that but I need to find them.

Electron 0.4.8 OTA upgrade warning
Whenever you upgrade from a version prior to 0.5.3, to a version after 0.5.3, you must always do an intermediate upgrade through 0.5.3. For example, if you upgrade from 0.4.8 (factory default) to 0.6.2, you need to upgrade first to 0.5.3, then upgrade again 0.6.2.

The reason is that in 0.6.0 Electron system firmware changed from 2 to 3 parts. The intermediate upgrade is necessary as 0.5.3 has 2 parts, but knows how to install 3 parts.

The Safe Mode Healer knows how to do this, but if you upgrade OTA manually you need to do the intermediate upgrade yourself.

Take a look here:


#12

Does particle update really not do that automatically? I had no issues jumping from 0.6.3 to 1.0.0 using particle update. Since Particle ships out devices at really old firmware versions and doesn’t specify particle update not being safe I believe it should be safe to do so. (Otherwise boy they really need to update that documentation)

EDIT: that was a photon not an electron, but I can try it on my electron right now


#13

That’s a different story tho’ - that’s why the upgrade warning is put in place.

Between v0.5.2 and v0.5.3 the Electron device OS was changed from using two part to using three parts and that transition can’t be taken in one go.

With Windows the npm way is not the best way to go.
The recommended way is the Particle CLI Windows Installer

https://docs.particle.io/tutorials/developer-tools/cli/#using-windows
If you installed via npm you should remove that version via npm uninstall -g particle-cli and reinstall via the installer.


#14

No one has suggested that particle update is not safe though? I don’t really care either way but I wish there would be some documentation about it.

Either way, the safest thing to do would be for @ascii to flash the firmware.bin they have using DFU mode and let the device auto update OTA, though it will use some data

EDIT: after following the instructions above to properly install the CLI, of course


#15

updating went well, i am really close to getting it up and running, its just complaining about this,

Error writing firmware: No such file or directory: Could not open file firmware.bin for reading

i confirmed that the bin file is in the proper directory.


#16

Above you said that your firmware file was in your sys32 folder? Is that the folder you are running the command from? Can you run dir and make sure you see the firmware file?


#17

i ran dir and it is visible there


#18

Are you still running as administrator? Can you try moving the file into a folder where permissions are less likely to be an issue, such as your Documents or Downloads folder and try running it there?


#19

yes, the problem is that then the particle command isnt recognised for some reason


#20

When you run as admin or when you move the file? As a mac guy, this sounds like it may be windows specific enough that someone else may need to chime in. Did you reinstall the CLI per the guidelines above?