[ISSUE] "Blue Screen of Death" when E-Series DevKit is connected to computer via USB

Recently purchased two E-Series DevKits which both have activated SIM cards. After following the basic instructions on installing the Particle Workbench VSCode and the Particle CLI I flashed my board. Upon flashing my board I immediately received the Blue Screen of Death (BSOD). My computer attempted to reboot multiple times, but to no avail as it got stuck in a BSOD loop. As soon as I unplugged the USB from the E-Series board my computer was able to start right up. Upon reconnecting the DevKit to the computer I received the BSOD error again so I found my problem.

• I have tried uninstalling the Particle Workbench and Particle CLI.
• I have re-installed both of these normally.
• I have reinstalled the CLI without the USB drivers selected.
• I have opened device manager and deleted all of the devices pertaining to Particle.
• I deleted all devices again as well as following instructions from this forum.
https://github.com/rickkas7/particle_notes/tree/master/debugging-windows-7-drivers
• I have completely uninstalled everything again and manually installed the DFU utility following
these instructions.
Tutorial: Installing DFU-Driver on Windows [24 Feb 2015]

On one of my more recent restarts due to the BSOD my computer ran a repair operation which rolled my system back to an earlier version. At this point I re-installed the Particle Workbench and CLI. I was able to connect my E-Series device without having it crash my computer. I then logged into my device through the CLI and requested the identity of my device so I could link it with my particle cloud. I recieved a “Serial Timeout” Error. I followed these instructions.

As soon as I held down the Reset and Mode buttons until the device was breathing Magenta my computer crashed again with the BSOD. I am again unable to access any part of my device.

Note: The only time I am able to connect to my device with the USB connected, the unit must be in DFU mode.

Checklist:

  • I am currently using the latest versions of VSCode and Particle workbench as I have just installed them and updated them.
  • I have disabled Antivirus.
  • I am not currently using any USB hubs or extensions, I have also disconnected all other USB connections.
  • I have tried multiple USB cables with the same result.
  • I am storing everything on my local drive.

Upon running Particle: Audit Environment command I receive the following message.

image

Any and all help would be greatly appreciated.

Thank you.

Hi there!

@rickkas7 has made the following suggestion:

It is possible that a copy of the old Particle serial driver installed. It may be hidden, but if it’s present it can cause a BSOD. Instructions for removing it are here: https://github.com/rickkas7/particle_notes/tree/master/fixing-windows-10-serial-drivers#the-old-serial-driver

Please keep us updated!

1 Like

Thank you I will follow these steps.

After following these steps there is no old electron driver showing up in the device manager. As soon as I connect the E-series device to my computer it is still immediately crashing and I don’t see a new device show up before it crashes.

I am able to connect that device to another computer and have it work. I am also able to connect an Argon device to my computer which doesn’t crash it. So it must be some specific interaction with the E-series and my computer. No other device has ever made my computer crash so this is new to me.

Hi there,

Can you run particle update followed by particle flash --usb tinker onto the E-series from the working computer?

Can you also please send a photo of your usb connection from the E-Series?

Thank you!