Can't register electron

I’m trying to setup an Electron - I went through the steps at setup.particle.com, putting in the SIM number, and after that it brought me to the screen where I could enter code. However, the Electron was still flashing that it couldn’t connect to the network. It did this for a few hours. I was in a basement so when I went out to run some errands I brought it with me. It eventually connected but I still don’t see it listed as a device.

If I run “particle serial list” it shows it: “Found 1 device connected via serial…”. But if I do “particle serial identify” it says “serial timed out”. Searching the forums I found suggestions to update the firmware (which I did) and to connect via PuTTY. I’m on Mac so I did “screen /dev/tty.usbmodem1411 9600”. This connects but I don’t get any output.

Is there anything else I should try? It’s been pulsing cyan for over 12 hours now without registering as a device.

Thanks!

If the device is breathing Cyan it should have a cloud connection. Try placing it in listening mode (by holding setup for ~4 seconds until it blinks dark blue), then try particle identify. Should that work, copy the deviceID. Then, reset the Electron and wait for it t reconnect to the cloud (breathing cyan). Then call particle device add [deviceID] to claim it to your account, provided you were logged in to the CLI already.

1 Like

That’s probably due to the fact that the default firmware is Tinker which doesn’t print anything to serial.

Once you have claimed your device you can try console.particle.io/devices and click your device to see the exposed functions (e.g. digitalWrite if your device is running Tinker)

1 Like

That worked perfectly, thank you!

1 Like

So your device is registered now, and up and running?

1 Like

Yup

2 Likes