[Solved] Doing deep update

Hello all,

I am a newbie in sparkcore. So please excuse me if this sounds a petty issue.

I want to do a deep update for the spark firmware as I read on forums that its necessary to do so if you want to get connected to a webpage. However, while doing so I get the following error:

Apparently I didn’t find a DFU device? util said
Error writing firmware… no dfu device found.

I have kept the core in dfu mode(the led blinks yellow). Still I cannot do the update. Also now after trying to do this update for several times, I cannot connect to the core anymore. Even after doing a factory reset.

Please suggest me. I am kind of lost now. As I am new to all this, I am not very sure which direction to proceed now.

Thank you in advance.

Make sure you have the DFU driver installed properly if you are on windows or try changing a USB cable. :slight_smile:

Hi @nj187 Sounds like you are using the Spark CLI with this command?

spark flash --usb cc3000

If so you also need to make sure you have the DFU driver installed, and DFU-UTIL is installed on your machine.



Hello BDub,

Thank you for a prompt reply. I am using a linux system. And I learned that I have a dfu-util version 0.5

Could that be a problem?

Also, I have the spark-cli installed. But not very sure if I am using it. Could you tell me if there is a certain procedure to use it? Or once its installed, I just us my normal command line?

Sorry for this petty query. But I am a bit lost now.

Possibly, since 0.8 is out… and most of the development for Spark has been done with dfu-util 0.7.

If you have Homebrew installed… try this:

brew update
brew upgrade dfu-util

Or if on a Linux machine check here for the right setup:

To use Spark-CLI open a terminal and type spark --version to check and see if your version reported is 0.4.4 and if not run sudo npm update -g spark-cli to upgrade it.

After that you can put your core into DFU mode and run the deep update:
spark flash --usb cc3000


I get the following now:

File downloaded successfully
Transitioning to dfuMANIFEST state
Error during download get_status

Not sure about the Error.


I just checked. And this seems to have worked.

I could connect the core again to the cloud.

thank you so much.

Now my actual task begins. I need to connect to a webpage (.php) which will then via twillio send a message to a number.
Could you give me any suggestions/guidance for the same?

You are going to want to look at http://docs.spark.io/firmware/#communication-tcpclient but I think this would be best done in it’s own thread (for easy searching). Would you mind creating a new topic if you have questions about connecting to a web page? I’m going to make this “solved” for now. Feel free to comment back if you have additional deep update issues.

Yes sure. I will create a new topic. thank you again.

Check these projects out…

1 Like