Having trouble updating Cores

So recently, my cores had been acting odd so I read through the forums, and decided that the firmware may be out of date. So I went and tried to update.

First, I did the spark (now particle) flash --factory tinker,
which worked.

Next I tried to do spark flash --usb cc3000, which gave me an error stating that I was missing the gcc-arm-none-eabi. I now have that, and I updated all the spark (now particle) cli. However, I still get this:

Found DFU device 1d50:607f
Apparently I didn't find a DFU device? util said  dfu-util 0.5

(C) 2005-2008 by Weston Schmidt, Harald Welte and OpenMoko Inc.
(C) 2010-2011 Tormod Volden (DfuSe support)
This program is Free Software and has ABSOLUTELY NO WARRANTY

dfu-util does currently only support DFU version 1.0

Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash  /0x08000000/20*001Ka,108*001Kg"
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=1, name="@SPI Flash : SST25x/0x00000000/512*04Kg" 

checking file  /usr/lib/node_modules/particle-cli/binaries/cc3000-patch-programmer.bin
spawning dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000:leave -D /usr/lib/node_modules/particle-cli/binaries/cc3000-patch-   programmer.bin
invalid dfuse address: 0x08005000:leave
Error writing firmware... 

Any help would be fantastic!

There is no dependency for gcc-arm-none-eabi so iā€™m not sure where the error is coming from.

Can you use particle flash --usb cc3000 instead?

This problem looks like the one where dfu-util 0.5 does not like the :leave syntax. Maybe you should try updating your dfu-util to a more recent version.

1 Like

Sharp :eyes: @bko!

The other way is to: