[Solved] Core not recognized over serial

Hello everyone,

I am attempting to read values over serial, but receive this message in the terminal:

I didn't find any cores available via serial
No serial port identified

I’ve connected one of my Cores to both a MacBook Pro and a PC, trying every USB port on each. Of my three Cores, this is the only one for which that message is displayed. Has anyone else encountered this issue and is there a way to resolve it?

Wondering if the issue was the code on each Core, I flashed the code from the “faulty” Core onto the others and the others worked fine. That single Core does not. Below is the code currently loaded:

#define STEPS 200
#define ADCwidth 12
#define ADCsteps pow(2, ADCwidth)
#define maxSpeed 256 //RPM (for test, using max LED value 255)

//Stepper stepper1(STEPS, D0, D1, D2, D3);

int potPin = A0;
int ledPin = D7;
int potVal = 0;
uint8_t speed = 0;

void setup() {
    pinMode(potPin, INPUT);
    pinMode(ledPin, OUTPUT); //LED brightness correlates to motor speed

void loop() {
    potVal = analogRead(potPin);
    speed = floor(potVal/(ADCsteps/maxSpeed));
    analogWrite(ledPin, speed);


void display() {
    Serial.print("Pot Val: ");
    Serial.print(" | ");
    Serial.print("Speed: ");

Finally, I flashed the “Blink An LED” app onto the Core and modified it to print the LEDstate. Terminal again displayed the above message.

Any help would be greatly appreciated.


Are you using Spark-cli and the command spark identify?

If you are, you should instead using spark serial monitor or any other Terminal program :wink:

Try swapping the USB cable and see what happens :wink:

Thanks @kennethlimcp. Switching cables doesn’t change anything.
I’m going to try to reset the Core and then re-flash the app.

Strange…it just appears to be that app. I reset the Core to default firmware, then wrote a simple app to print sequential integers and it worked just fine. Going to test with other apps, but it appears to just be that one.