Can't connect over network nor USB


Yesterday I received my spark core and I have tried to set it up ever since. I did not succeed in connecting it to the Wifi. Here is what I tried :

  • I started by using the Android App for setting up the Spark Core. I tried this several times but the result was always the same : The light kept blinking white, so nothing changed… The app times out, and tells me that no cores are found

  • I tried the same on an iPad. The result was exactly the same

  • Because I thought that something was wrong with my network, I set up my Android phone as a Hotspot, and used the iPad app, to connect the Spark to that network. Same result

  • I connected the Spark over USB to my Mac and tried opening a connection with CoolTerm. I could not connect to the Spark since it wasn’t listed as one of the possible Serial devices to connect to. ( Could be related to a Mavericks bug ? ( The command sudo ls /dev/tty.u* tells me that no such devices exist.

  • I connected the Spark over USB with a Windows computer and went to Device Manager and scanned for hardware changes, but the Spark did not show up in Unknown devices

I am kind of out of options. Anybody else with an idea ?

I was getting exactly same issue on my Mac/Mavericks with CoolTerm which stumped me for a while. In the end I found the serial monitor on the arduino IDE worked fine for me ( if you dont have it) - though i had to juggle the NL/CR combination otherwise both SSID and password request were coming up at once - i recall i had to set it to just NL.

Hi, Thanks for trying to help me. The Arduino IDE does not help me either, since the Spark is not listed along with my serial devices. I am starting to think that my spark was DOA.


You mentioned your core is blinking white? Can we check and see if you can get it blinking blue by doing a factory reset? – Plug in your core, hold down both buttons, release the reset button and keep holding the mode button. Your core should start blinking yellow, and then fast blink white and reset.

When your core is blinking blue you’ll be able to configure the wifi via the mobile apps or over USB serial (it won’t show up as a serial device unless it’s blinking blue or running user-firmware).

If we can’t change the LED color at all by doing these steps, can you email me at


Hi Dave,

Yes, my core is blinking white with maybe a very light touch of blue in there.
I already tried multiple factory resets before and I never saw any color but this white ( apart from the Yellow during factory reset ).

I will send you an e-mail about this problem

1 Like

Upon receiving my two spark cores I did feel the excitement most people have while unpacking. However, I face similar problems with my two spark cores. I cannot connect. Details are:

Core 1 (chip antenna, lot 7 60921 27210 7)
This core only lits the small blue led located near the golden star at the board. The big RGB led remains idle i.e. does lit at all. No luck attempting a factory reset. Any suggestions what is going on?

Core 2 (chip antenna, lot 7 60921 27210 7)
The RGB led of the second core lits allright and flashes blue and then turns to green. But it won’t connect to the cloud. I have tried the options in the getting started pages and in the forum. Still I have been unsuccesfull passing the stage of green blinking. After providing SSID/passwd the app gives error ‘No Cores Found’. The core can be accessed over the terminal (OSX Mavericks). After giving in SSID/passwd the core replies that credentials are stored but then no change over from green to magenta. Any suggestions what I do wrong here?


Cores are under evaluation using a mac (OSX Mavericks),
an Ubee evw3200 wifi router and an Iphone5 IOS7 to run the spark core app.

Hi @henry - your “Core 1” is exhibiting behavior which means that it didn’t get flashed with firmware on the manufacturing line. Shoot me an email at zach at spark dot io and we’ll get you a replacement.

“Core 2” could be a bunch of different issues, perhaps due to your Wi-Fi router, or perhaps due to firmware on the Spark Core. Have you gone through these troubleshooting steps?

After carefully reading the latest posts at the forum I have been able to get my number 2 core up and running using the usb connection. I had to replace the firmware (quick route). After that I could connect by OSX terminal program to receive the core ID and to set the SSID/pw. With the upgrade of the firmware, the core went through the color cycles decribed at getting started web pages and my core started breathing in cyan. Using the build section at I was able to run the core with the blink example. I was impressed to see this tiny piece of art (the spark core) doing its work.

Still, there are some problems left.

  1. My other core remains silent. There is no-way getting it up and running. It is stuck with the little blue diode (at D7) lighting up continuously whereas the RGB led remains dead. Factory reset, disconnecting/reconnecting, other cables, a 1A usb supply, …does not change anything.
  2. The spark core app does not work. It cannot find my core although the blink example is working.

Can anyone from the Spark team have a look into these issues?

@henry for issue 1, please email me at zach at spark dot io and we’ll get you a replacement.

for issue 2, it sounds like you’ve installed your own firmware, which means that “Tinker” is no longer installed. Try re-flashing Tinker from the app (menu on the left in the iphone app, menu on the right in the android app) and Tinker should work again as expected.

1 Like