Do I have a BAD Core?

I got my Core last December and while I love the concept, I have just not been able to build apps reliably. I think now that I have a bad Core and am wondering if that is the case. Here is the list of issues I have seen:

  1. I have never been able to get either the Android app or the IOS app to connect to the Core. The App will hang on Connect and my Mac will not be able to connect to the network on that same Wifi network. Pings to local addresses will timeout as long as the App is still trying to Connect. As soon as it stops trying the pings work again.

  2. So on to the CLI. Being a CLI programmer, this works well, except getting the Serial connection to my Mac works less than half the time. I have to physically connect and disconnect to make this work. I have upgraded to the latest firmware, but still the problems persist.

  3. Flashing via the Web IDE works 20% of the time. This makes getting new programs on the Core very tedious. It does not make a difference if the program is simple or complex, it will fail most of the time. The Core then gets into a state where the D7 Led is on and the RGB led has no color. RST does not work, the Core needs to be Factory reset and I have to start all over again.

I scoured the forum and did not find anyone with all these issues. I would be delighted to port my Sensor+Arduino Ethernet to this platform, but it has been a rough ride so far.

What would you experienced folks suggest ?

thx,

AJ

I’m not too sure what’s the problem you are describing.

Your Macbook not being able to connect to the network has nothing to do with the spark core.

1.) Perform a CC3000 patch via Spark-cli

spark flash --usb cc3000 in DFU mode and the core will blink magenta while patching and revert back to blinking yellow.

Use spark flash --usb tinker to program the default firmware. The core should now blink blue.

Send in your wifI credentials using spark setup wifi over Serial and see the RGB led status.let us know how it goes and which colour are you at. :slight_smile:

1 Like

Since you have a mac, try Terminal. While in terminal for the CLI, press CMD+T for a new tab. Make sure your Core is blinking blue (Listening Mode) or running some Serial code. Then type screen /dev/cu.usb and hit TAB a couple times to auto complete or get a list of available serial ports. Hopefully you’ll just have one. If you leave things at the default speed of 9600 baud, you only need a command like screen /dev/cu.usbmodem14131 but if you want to use a different baud like 115200, you can type screen /dev/cu.usbmodem14131 115200 and hit enter. You’ll have a serial terminal in terminal :slight_smile: CMD+W to close the tab. And when you re-open the tab with CMD+T you can use the UP arrow key to bring back the last command quickly and reopen the serial terminal.

In addition to Kenneth’s two CLI commands, also run spark flash --factory tinker to update your factory firmware to the newest.

What type of router do you have and what frequency, channel and mode is it running in?

1 Like

ok, so I did the CC3000 patch and the tinker flash. The core will still not connect to either the android app or the IOS app.

So I went back to using the CLI. Things worked i.e. new compiled programs were flashed correctly for a while (4 times). Now it is not working again. Symptoms:

a) Breathing Cyan, but code cannot be flashed. Spark List shows Core is offline.
b) So I Reset it, put it into blinking Blue mode again and reentered the Wifi Credentials via Spark setup wifi.
c) Core is breathing Cyan again but still offline.

I have tried two Wifi channels: 1 and 9. 9 is relatively empty at my residence hence I use it. But 1 does not work either.

My other issue is that once working, these sensors will be in remote locations. Wifi setup will need to work over an Android phone (no computer = no CLI).

thx,

AJ

I have tried two routers:
a) Airport Extreme. Channel 1 and 9. 2.4Ghz b/g/n
b) ASUS RT-56U. Channel 1 and 9 2.4Ghz b/g/n

b) seems to work better.

AJ

Can you setup a Wifi hotspot on your mobile with security type OPEN and see if you can get the core connected and listed online?

Breathing cyan but listed offline sounds weird. Did you ever change the server public keys before? Maybe to test out the local :cloud:?

Also, what is the configuration on your router? WPA or WPA2 etc…

On your ASUS router, try to make sure Legacy mode is enabled. Also go to ASUS’s support site and make sure you have the latest firmware version listed. I have an ASUS router, slightly newer model, and it has an update utility built-in that said it was latest firmware but in reality it wasn’t. The difference was with the latest I could connect cores to my WiFi when the SSID wasn’t being broadcast, but with the slightly older version they would not connect until SSID was broadcast. So weirdness can happen with any piece of firmware… make sure you have the latest :wink:

This afternoon when I was traveling, I had set up the Core with a hotspot from my Dad’s phone (Nexus5/WPA2) and it worked fine.

No I have not changed the server keys before. I am trying to avoid going thru the flash sequence all over again. But I may try to compile locally and flash just the new program.

thx,

AJ

Rather than update the firmware on the router (my Dad wouldn’t let me), I tried yet another router and unfortunately the same result.

spark list shows offline.
Now the Core goes into a while sequence of breathing, then blinking cyan, then blinking red, then green, then back to breathing cyan.

Meanwhile I was able to flash a new program using spark flash --usb and the programs works correctly (when the Core is connected) from the serial monitor.

The new router is 3 feet away from the Core:
Channel 11
2.4 Ghz
WPA2

thx

AJ

I would try spark keys doctor core_id in DFU mode to change the keys since it seems like the core should indeed be online with a breathing cyan status.

Will also program the default tinker app to make sure the program isn’t causing an issu3.