Core does'nt connect to Spark cloud

I’ve used “SET UP YOUR CORE OVER USB” to setup wifi connection account and this the answer of my core:
Thanks! Wait about 7 seconds while I save those credentials…

Awesome. Now we’ll connect!

If you see a pulsing cyan light, your Spark Core
has connected to the Cloud and is ready to go!

If your LED flashes red or you encounter any other problems,
visit to debug.

Spark <3 you!

BUT the led flashing green so i’ve look my router status and there’s no new ip assigned from my dhcp.
This means that my core is not connected to my wifi !!
My router is a standard router and i’ve no problem to connect all devices (iphones, ipads, notebooks…)
Router firewall is off, wifi key is channel 1, WPA-PSK TKIP-AES 256 bit, dhcp on

what’s wrong ?

1 Like

Might be entering the data wrong, not your fault… but some of the Serial Terminal programs will mess up the line endings which corrupt your Wifi credentials.

Do not use the Arduino IDE.

Do use:
Cool Term
Tera Term VT


i’ve used Cool Term and my data account it’s right, i’ve some other devices connected on my wlan !

Did you already attach anything to the core? I just had some issues connecting a core via the iPhone app. This only worked after I removed all other components (trying to get color lcd up and running). Might be dumb luck though…

If your core is not a uFL type (with no ext. antenna connected), and you are super sure there is no way the data is getting entered wrong, and you’ve done it the same way for other Cores that work just fine in the same area powered by the same power supply… and you tried the SmartConfig app …and Factory Reset already…

If this core connected to the Cloud at least once, it might need to have the bootloader reflashed.

If this core never connected to the Cloud, it might have a problem with the Wifi hardware/antenna.

Sorry I’m not thinking of any other issues there may be, can anyone else think of something I missed?

Can you tell us exactly what model router, and what firmware version? The 2.4Ghz channel is 1 you said? Did you try WPA2, or WPA when configuring over serial?


Finally I managed to activate the module by powering it alone and using iphone
And really weird that i have been unable to activate it via serial usb saw that the wpa key is the same

I think you hate to enhance the activation tools, but anyway, now i’m ready to develope my first app :smiley:

Hi @blondie63,

Totally, I’m hoping we can deliver a version of the command line tool at the end of this sprint. I’m hoping that will greatly simplify a lot of common tasks, and also provide some examples for people to build on! :smiley: