Unable to connect to cloud , tried all methods , no success

Hello People,
My Spark maker kit arrived couple of days ago, ever since it’s arrival I have been trying to connect my core to the cloud.It goes to that blinking green state and then keeps on blinking green , I have tried configuring it via USB(serial connection method), Android app but no success at all . I have tried resetting it to the stock settings , clearing all wifi credentials using the mode button . All it does is , goes to blue blinking stage , then I try to enter the SSID and password and it keeps on blinking green.No matter what I do it denies to breathe , flash that much wanted cyan.

Router model: D- link DSL-2730U
Security:WPA2-PSK (Tried all possible encryption modes)
Is well within the said range of the core.

What do I need to do in order to get my core connected to the cloud?
Any help?

(Sorry for reposting it but I posted it in reply to someone , thought it wasn’t a good idea so.)

do you have dhcp enabled on the router?


try to keep the same issue to one thread.

We will be able to help you solve to faster that way. Thanks!

I just realized this is a duplicate post. Original thread is here: https://community.spark.io/t/failed-connecting-to-wifi/648/205

Hello Rishabh,
I’m sorry about the trouble you are going through.
Just as a sanity check, does your Core have an onboard chip antenna or a uFL connector? In case of a uFL connector, the Core will not connect unless you have an antenna plugged in.

Have you tried setting up the Core over a different network?