Can't connect Spark Core to my WiFi net [SOLVED]

I have just received my Core and I have installed the Windows driver (I am working with an Windows 8.1 laptop and with a HTC One Android phone with 4.4.2 version) and connected it by the USB cable to the laptop. The LEDS puts in cyan and flashing 3 times and them the blue led started to blink (listen mode if I am not wrong).
I have installed the apk, connected my mobile phone to my LAN by WiFi. When I start the app it detects me the SSID of the net and when I write my password (I have tried several times) it did not connect.
I have tried with other Android Phone and the result was the same. I have also tried generating a new SSID using one Android Phone as a Router Wifi but the results were the same.

After that I have tried to connect via USB. I have tried with Putty (Connection-Serial) choosing the port (COM8 in my case), 9600, 8,1,None,Xon/xoff flow control and when I press the OPEN button nothing happens.

I have also tried with the serial monitor of arduino and nothings appears (it seems nothing is reading or sending).

What should I do now? May be installing a new firmware vesion, trying in other wireless network?

Welcom @javier_pelaez!

What are your WiFi settings (WPA, WEP, open, Passphrase length should be <= 31, …).
If your Core would happen to be one of the earlier batches it might not like WEP or open.

When installing the Core drivers under Win8.x you’ll have to allow unsigned drivers first - which is a bit more troublesome the pre 8.0.
Was you RGB-LED blue when you tried the USB connection? If not press and hold the MODE button for about 3sec, till it turns blue and then press OPEN - not before, otherwise the Core gets mapped to another COM.

I use putty on my Win8.1 tablet with (115200, 8, 1, None, XON/XOFF).

1 Like

The Key it is a WPA2-Personal key with 20 characteres.
I do not have problems with the driver installation. It is recongnized as “Spark Core with Wifi and Arduino Compatibility”.
When I plug the device in the USB port the blue led is blinking.

Does your core enters solid blue when you send Wifi credentials over wifi?

1 Like

When you connect the Core via USB, do you hear the “Windows device connected” sound?
Have you checked in Device Manager under “Connections (COM & LPT)” if your Core was detected as “Spark Core with WiFi and Arduino Compatibility (COMxx)”?

What do you mean with [quote=“javier_pelaez, post:1, topic:3861”]
After that I have tried to connect via USB. I have tried with Putty (Connection-Serial) choosing the port (COM8 in my case), 9600, 8,1,None,Xon/xoff flow control and when I press the OPEN button nothing happens.

Does your putty window just start and nothing else? That’s just fine. Press “w” and the Core will tell you what to do.

1 Like

The blue LED was always blinking, never solid.

I have checked that in the PORT list of windows appears in COM8, when I click in OPEN button the typical sound of windows error sounds and nothing happens, the screen doesn’t change.

Now I have tried the device in other network and it works. I do not know what happens in the other net and I do not know why I cannot connect via USB.

If possible, compare with the other network that works.

Like the security type and mode (a/b/g/n uto etc)

High chance the WPA2 is causing the problem. Let’s focus on getting it to connect and resolve the USB later. It might be related but let’s isolate the issue 1st since the core managed to connect to other networks.

Try changing to WEP or WPA and connect again.

Be in a good range and use password with non unique characters :slight_smile:

1 Like

Both networks have WPA2 Personal password. It is true that in the first case the network has a 20 characters password and, in this case, it is a password with only numbers on it and 10 characters. In both the coverage range was excellent (i was next to the router).
In the first case (the one in which the device doesn’t work) the password had numbers and standard letters.

Have you checked the channel number of the router that does not work? You need to be on channel 11 or lower right now.

1 Like

I have just realized that the password of the networks wich works it’s a WPA password (not a WPA2 personal password) and the network which doesn’t work was a WPA2 password :frowning:

The USB problem could be now face up.

Thanks to everybody.

So could you change to WPA or like what @bko said, check the channel settings to be 11 or lower

1 Like

That’s it, with a network with a WPA pass it works as a charm.

1 Like

Great! Let’s solve the USB problem now… are you on windows?

Yes, windows 8.1. Neither the putty nor the Serial Monitor seem to work.

Since you got the WiFi solved, you might want to flash a very simple sketch via Web IDE (aka Sparkulator :wink: ) that performs a Serial.begin(); to make the Core connect via serial (without going into listening mode - blue RGB).


int i = 0;

void setup()
  pinMode(D7, OUTPUT);

void loop()
  digitalWrite(D7, HIGH);  
  Serial.print("Hello, world! ");
  digitalWrite(D7, LOW);

This way you’ll get additionally to a serial test an updated Core firmware that should support WPA2, WEP and open WiFi.
Once you have been able to serial connect, you can reflash the original Tinker firmware just via the Tinker app.

Other things you could check:
USB cable deffect?
Uninstall/reinstall spark_core.inf
Does the Core disappear and reappear along with the Windows device disconnect/connect tune in Device Manager when you press the RESET button on the Core?
Have a look in this thread especially post 30 :wink:

1 Like

Thank you very much, it is a little bit ashamed but I was not created a session in PuTTY, I have been reading some helping notes and now I receive the SSID request, etc. Now I can “speak” with the Spark Core. Thank you very much to all of you.

I will do what you (ScruffR) have told me in order to update the firmware version. Thanks for such a good support. I will tell you if I have some troubles updating the Firmware.