Android App can't find my Core and no serial connection

Hi, I just got my Spark Core and I’m trying to set it up.

I went through the procedure and I see the LEDs flash in the proper sequence but the Android app says that it can’t find any cores. I did read that there were problems with certain Android phones. I’m using a Samsung Galaxy S5.

I also have a problem where my PC will not recognize the core. The first time I plugged in my Core Windows reported that it could not install a driver. I then downloaded the driver and re-plugged in the driver. I never get a report that it could not install a driver to even point it at the driver I downloaded. I also checked device manager and there are no unrecognized devices there either where I could update the driver.

Any and all help is appreciated!

You don’t need a driver to send in Wifi credentials.

Just make sure it is Blinking blue and use a serial terminal to send in wifi credentials :wink:

1 Like

Windows can be a bit picky with USB connections - it might be a good idea to reboot.

Which LED colors do you see? You should see the core first show white, then flash dark blue (not cyan). This means it’s listening for WiFi credentials. If it’s not showing blue, hold the mode button for 3 seconds and the LED will turn blue. describes this in more detail.

Once blue, your PC will recognize the core and you should also see it on your phone. You can check the PC sees the core by looking for “Spark Core” under Ports in Device Manager.

Try the Connection steps listed in the docs and let us know where you see any deviation. :smile:

I actually got it all working.

I have to say I forget how I got the serial connection going.

The problem with the Spark Android app was incompatibility with my Samsung Galaxy S5. It actually sets the WiFi parameters of the Spark Core but the app never realizes that it worked. I tried again with my Android tablet and it worked perfectly.

Now I’m on to getting local dev environment working.

1 Like