No cores found - android app won't claim

Hi, just received my spark core and, although it took a while, it looks like it’s connected - it’s flashing yellow/green rapidly, but the Android app is not offering any way to name the core. The app shows “Nor cores found. Try again” The website doesn’t show the core name either.

I’ve tried resetting as per the docs on rebooting/resetting but no luck. Is there something else I can try?

Hi @ghchinoy - this means that the Core is not being claimed. You can claim it manually through the website, follow these instructions:

http://docs.spark.io/#/connect/claiming-your-core

Let us know how that works for you!

Actually just re-read your post; if it’s flashing green, then it means it’s attempting to connect to Wi-Fi but has not yet succeeded. Did you get a u.FL Core? If so, did you connect an antenna?

@zach thanks for responding! I have a chip antenna. I’m on my Chromebook right now, but I’ll hop to a different machine and give it a try. Thanks!

Hey @ghchinoy,

Just to check, where in the light sequence is your core now, here’s what you should see normally:

  • Slow flashing blue (in listening mode, fresh out of the box)
  • When connecting (after sending creds over serial / mobile app):
    • White (starting up)
    • Blinking green (connecting to Wifi)
    • Fast cyan (connecting to the cloud)
    • Breathing cyan (connected)
    • Flashing Magenta (updating)

Is it flashing yellow/red (after connecting to Cloud but before fully connected?), or is it just always flashing yellow, and there are no changes to the lights otherwise?

Thanks!
David

@Dave Thanks for that reference, that’s handy.

Sometimes (like just now), after a reboot - the Android app won’t be able to pass the wifi connection to the core and it’ll remain blinking blue, slowly.

Attached is a short video of the previous issue - blinking rapidly but not being claimed.
Also, I have a Netgear R6300 wifi router that has b/g and n (two separate SSIDs). I’ve been trying the b/g.

Video of rapid yellow/green blinking

Hi @ghchinoy,

Thank you for sending a video of the lights on your core, that is super helpful. I think that fast orange flashing is indicating a key problem on the core. I’m working on a tool that will help make this easy to resolve, there are manual steps in the meantime if you want to get back up and running. I just posted these here:

Howdy

I’m not the original guy but I’ve been having this same problem, except my spark core only flashes green or blue. It has never gone to any other colours. I’ve tried it on two seperate routers and one of the routers had two SSID’s.

I’ve tried to connect over USB but my computer has hidden the serial ports and I’m still trying to figure out where they are.

Thanks

Hey @Josh

This is maybe a silly question, but I know I’ve done this at least a few times. Is your other core a u.fl core? Do you have an antenna attached?

Thanks!
David

I don’t think so, mine has only got the chip on top.

I didn’t receive a connector and I’m pretty sure I ordered the chip version from kickstarter.

Hey @Josh,

Cool, thanks for replying. Sounds like your core is really close, but can’t connect to your network. The core needs an 802.11(b or g) network, and I think certain models of android phones can have trouble with the over-the-air smart config.

Sorry if you’ve been there already, but have you had a chance to try the troubleshooting steps in the guide? http://docs.spark.io/#/connect/troubleshooting

Yeah, I’ve got the Nexus 5 with the newest Android version (4.4) so that might be a problem.

I’ve tried all the steps in the troubleshooting section and none of them seem to help.

@Josh - what sort of computer do you have? Programming over USB’s going to be your best bet here.

I built it myself, but it’s running windows 7 with a Z773-UD3H motherboard, if that’s any help.

Hi, all - as an update, I was able to successfully connect my Core to my wifi and the spark internets by following @Dave 's link above. I did have to use the USB driver referenced on this thread in order for my Windows 7 machine to recognize a COM port for the Core (prior to step 8). After that, things went smoothly and the spark.io team entered my new public key.

1 Like

Hi.
I just tried my Core for the first time tonight.
MY phone, a Motorola (now Google) Moto X did not connect.
I tried the USB serial connection.
I was able to get the Core ID.
However, when I go into the IDE and enter the Core ID in the “claim your core” field, I get the error message: “Could not claim core”.
I tried it again after resetting the memory. Still no go.
Any suggestions?

P.S. the resetting your password for Build does not show a confirmation(at least in Chrome).

Hey @Roger,

Just to check, before you can claim your core, it should be connected to the cloud and either updating “flashing magenta” or connected and “breathing cyan.” If that’s the case and it’s still not working, can you email me at david@spark.io / hello@spark.io with your core id, from the email account you’re using on the site?

Thanks!
David