Startup without using App

Hi there!

I just got my Spark Core through the post yesterday and I’m thrilled to get it working… even though it was a lot harder than I thought!

First off, I don’t have an Android or an ios device, so the only choices I had to start with were TI’s SmartConfig or USB. I tried the SmartConfig on my Windows 8 PC and… no success. I tried turning off firewalls, opening all sorts of ports, but no luck. I also tried @ghawkins SmartConfig (, but again no luck. So USB it is…

I hooked up my Spark Core to my computer and tried to Putty straight into it. Unfortunately I think there has to be a driver to do this first – I couldn’t set up a COM port for Putty to talk to. Is there any driver/setup I’m missing here? Regardless, I tried my (Arch) Linux PC and managed to /tty/ACM0 into it (again with Putty) and got the setup console. So now I have a fully operational core!

Rant over, I suppose my questions are: are there any drivers for Windows to get the core to communicate over serial USB and is there any way to add better documentation for setting up a core without the app? I understand these are still early days, but I feel setup is too dependant on the app! Also, but slightly off-topic, how do you set the name of a core? Does this really matter or do you always have to use the device ID for programming?

1 Like

Hi Zigmat!

Very cool that you got it going under linux! Yes we have a windows driver, and I need to get that up on the documentation page asap. In the meantime you can get it here:

This driver is really simple (I recommend opening it in a text editor). All it does is tell Windows the core can be treated as a virtual com port. You might see a giant scary warning dialog when installing it, but you can open it and see it’s not doing anything weird. :smile:

I’ll be adding a nice guide with pictures and stuff, but you should be able to install it by selecting “Update Driver” for the core, and browsing to your downloads directory and it should find it.


Also, when you were using the Smart Config apps, did you set the AES key to sparkdevices2013?

Dave: Perfect, the Windows driver works like a charm! I had to go though installing without driver signatures, but has a useful guide in case anybody else wants to try. I had to reset my core before it was recognised by my computer (MODE button held for 10 seconds) and after plugging it in and installing the driver it was fine.

zach: I tried to use the AES key with Smart Config, but still no success. I’m hoping to test with an Android phone soon to see if it’s my network acting up.


Spark Team, can you maybe add a signature to the driver? Is there a place where I can suggest backlog tasks? I just think it would make it more accessible to noobies/children/or generally non-hacker types. This is a really cool device to get people psyched about technology, would love to see this quick fix to make it easier to use for first-timers.

1 Like

@hogpog it’s definitely on our backlog along with a more comprehensive solution to be able to use the Core over USB without installing all the dependencies yourself. Agreed we’d like to make it easier :slight_smile:

Took me long enough, windows driver is signed!