Can't access port

My Spark Core is in blue flashing mode, and I try using CoolTerm to access the port in order to setup the credentials, but the port doesn’t appear in CoolTerm, therefore I can’t set it up.
Could someone let me know of how to resolve the issue?

Have you tried using the Tinker app? Or perhaps the Spark CLI might be off use. has a whole page set up to help you to get up and running.

Hi @Louis,

If you’re using CoolTerm on a Mac, I would recommend trying the spark-cli ( ) if you haven’t yet. You can use the command spark serial list to have the CLI scan for cores.

If you have a core flashing blue, but it’s not showing up, there are a few things to try just as sanity checks:

1.) Try a different USB cable, and make sure you’re directly connected to the computer, and not through a usb 3.0 port.

2.) try a factory reset on the core -

3.) Make sure the core is adequately powered, nothing is shorted. If you have the core breadboarded in a project, it’s possible something is draining the voltage, or if you have your own custom firmware loaded it could be monopolizing the serial port, etc.

I hope that helps!


Changed the cable…it worked!
Thanks a lot for the suggestion!

1 Like