Solid Blue, Unable to Connect to Core over USB - No Serial Port OSX [SOLVED]

I am working with a previously operational core on OSX 10.8. I was changing the network config via USB but realized I made a mistake. I put the core into listening mode again by holding the mode button and the led turned to solid blue instead of flashing. At this point, coolterm did not find the USB port that was previously there. I tried to reset the memory by holding mode for 10+ seconds. Still solid blue and no serial port. I even went as far as flashing the firmware again with dfu-util. No change in the situation. I cannot use my iPhone to access the core either. Please advise.

When you say “flashing the firmware again with dfu-util” you were able to get it into the flashing yellow state (DFU mode) and program the core-firmware.bin or something else?

Can you try a factory reset? Hold both buttons down, let go of reset… hold mode for until you see white flashing LED… then wait for it to come back to blinking blue to enter your credentials again.

Yes, I was able to put in DFU mode by holding down the mode and reset buttons, then releasing reset. It blinked yellow, I used dfu-util to reflash with core-firmware.bin Didn’t change the situation. I just tried a factory reset as per your instructions. It worked, and it went back to flashing blue. I connected via coolterm over usb and changed wifi credentials. Now just blinking green. I have two cores and I am doing the same to both. The other one is now connected to the network and i can use tinker with it. This one is still giving me problems. I just tried resetting it (not factory reset) and now it is fast blinking orange and periodically fast blinking cyan.

If you can still DFU the flaky one, can you try this latest Factory Core-Firmware BIN?
https://github.com/spark/core-firmware/raw/spark_2/build/core-firmware.bin

Maybe you already have… not sure :smile:

I have gotten into a couple situations now where I had to completely erase the memory from 0x8005000 all the way up to get my core to respond again. This is where the core-firmware.bin goes, so if you are able to reprogram that with the link above, and it’s still acting funny… (orange flash) You might need new Keys:

Ok, I tried flashing the core-firmware you linked and nothing changed. I went ahead and started to perform the steps in the linked thread. The procedure fails at step #7:

dfu-util -d 1d50:607f -a 1 -s 0x00002000 -v -D core_private.der

Here’s the terminal output:

Bretts-MacBook-Pro:core_ssl balogh$ sudo dfu-util -d 1d50:607f -a 1 -s 0x00002000 -v -D core_private.der
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Filter on vendor = 0x1d50 product = 0x607f
Opening DFU capable USB device… ID 1d50:607f
Run-time device DFU version 011a
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=1, name="@SPI Flash : SST25x/0x00000000/512*04Kg"
Claiming USB DFU Interface…
Setting Alternate Setting #1
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
No valid DFU suffix signature
Warning: File has no DFU suffix
DfuSe interface name: "SPI Flash : SST25x"
Memory segment at 0x00000000 512 x 4096 = 2097152 (rew)
Downloading to address = 0x00002000, size = 607
Poll timeout 50 ms
Download from image offset 00000000 to memory 00002000-0000225e, size 607
Poll timeout 30 ms
Error during download get_status
Failed to write whole chunk: -7 of 607 bytes

Hi Guys,

You are absolutely on the right track, sorry I’m coming late to this thread. :smile:

The dfu write has a bug where it doesn’t like writing odd length files (I know…), if you add a single byte to the end of your der file, or regenerate your key until the der file is an even number of bytes, it should write okay. The command line tool will fix this for you. (When it’s available)

1 Like

Hi Dave, Thanks!

FInally made it through the process:

Yes, key has to be an even number of bytes.

The cloud public key file was a little hard to get because there’s some problem with the site’s certificate. Used wget with --no-check-certificate. I emailed David and info with the key and the ID.

1 Like