Serial not working [Cable issue]

hi Everyboy!

Today i installed Yosemite (mac 10.10), and tried to setup a new core with the command “spark setup”. It worked flawlessly so far (on older os), but with this one i’m getting the following error message:

  • Is your core blinking blue? Then press ENTER - Potentially unhandled rejection [2] No serial port identified (WARNING: non-Error used)

Also for some reason i cannot see the cores on the serial port, maybe it is related.

I tried to upgrade spark-cli, but same result.

Is anyone experiencing the same?

Noten

1 Like

Hey @Noten,

spark setup is for you to first login to spark :cloud: and setup a new core for the first time.

Once you successfully logged on and don’t need to claim a core, simply do this:

CTRL + c

You are trying to see cores via serial port as in to:

1.) Configure Wifi

2.) Use the Serial functions?

3.) Check the core id?

hey @kennethlimcp!

Yes, i’m completely aware of the functions of the spark command line tool. I have CoolTerm installed as well, and that didn’t see my core. So i thought i will try the wifi setup with the command line tool and it also didn’t see the Core (it dropped the error message i pasted in my first message).

It found the core ID, although it was not able to set the wifi credentials for the core. (With the iphone app it worked properly, so it is not the core’s issue for sure, and before Yosemite this command line tool was also ok.) Bit clueless now i have to tell.

Noten

What does w say when you use Coolterm with the core in blinking blue mode?

Problem is i can’t even see the opened serial port in CoolTerm :frowning: It’s like it is not opening the port.

You will first need to place it in blinking blue mode, rescan the serial port in Coolterm and choose the usbmodem

yup, but the “usbmodem” is not showing up. That is the core of the problem here :slight_smile:

Ah… Serial should work pretty much easily so maybe you can try changing the USB cable to make sure things are fine.

Another way is to place the core in DFU mode (blinking yellow) and try doing spark flash --usb tinker

If this fails as well, it might be a cable issue. :wink:

Okay, it was the USB :smirk:

Sorry, this is so trivial, i should have checked it.

1 Like

I changed the title to better reflect the issue.

1 Like

I am experiencing this same issue and have resorted to vigorously purchasing two additional cables. Could there be another issue causing this?

Wow, I think you are on the right track! Until you confirm it is NOT the cable, by using quality cables, we cannot substantiate any other cause. :wink: