Serial Port Not Open?

Hello,

I am trying to set up my Spark Core through the CLI beacuse I do not have access to a non enterprise wifi network. However, when I run ‘spark setup’ it gives me this error. Does anyone have any idea what could be the cause?

  • Is your core blinking blue? Then press ENTER - Potentially unhandled rejection Error: Serialport not open.
    at SerialPortFactory.SerialPort.close (C:\Users\Z013M53\AppData\Roaming\npm\node_modules\spark-cli\node_modules\serialport\serialport.js:349:17)
    at C:\Users\Z013M53\AppData\Roaming\npm\node_modules\spark-cli\commands\SerialCommand.js:485:24
    at C:\Users\Z013M53\AppData\Roaming\npm\node_modules\spark-cli\node_modules\when\lib\decorators\flow.js:141:6
    at tryCatchReject (C:\Users\Z013M53\AppData\Roaming\npm\node_modules\spark-cli\node_modules\when\lib\makePromise.js:790:14)
    at RejectedHandler.when (C:\Users\Z013M53\AppData\Roaming\npm\node_modules\spark-cli\node_modules\when\lib\makePromise.js:658:9)
    at DeferredHandler.run (C:\Users\Z013M53\AppData\Roaming\npm\node_modules\spark-cli\node_modules\when\lib\makePromise.js:444:13)
    at Scheduler._drain (C:\Users\Z013M53\AppData\Roaming\npm\node_modules\spark-cli\node_modules\when\lib\scheduler.js:56:14)
    at Scheduler.drain (C:\Users\Z013M53\AppData\Roaming\npm\node_modules\spark-cli\node_modules\when\lib\scheduler.js:21:9)
    at process._tickCallback (node.js:419:13)

Hi @AlexMiller,

Hmm, I’m guessing you need the Windows virtual serial port driver, it should be here under “Connect over USB” - http://docs.spark.io/connect/#connecting-your-core-connect-over-usb

Thanks!
David

1 Like

@Dave I have the driver installed. I am able to connect to it to get the device ID or set up the wifi SSID, but I cannot to anything else beyond that.

Hi @AlexMiller,

Oh, cool! I guess I’m confused, is the CLI just throwing that error during setup? Do the other CLI commands work, or are you using another serial tool to setup wifi? Are you running the command in an Admin command prompt? Can you show what version of node / windows / etc you’re using?

Thanks!
David

I’m also having a lot of problems with my Serial Port.
When i got my 2 cores i could only get at serial connection to one of them, and after a lot of frustrating thinking i figured out something was wrung with one of the USB cables. I was allow to go into DFU-mode at to upload code and all that, but when i tried to open the COM-port nothing happened, but only with one of the cables.

For at long time that was fine for me, but now I’m having troubles again, i cant see the spark core as a COM-port on my PC no matter what i try. I’ve tried playing with the drivers, and SOMETIMES it shows as an unknown devise, and sometimes nothing happens.

Then i remembered my problems with the cables and i have tried every single one i my house, but non of them allows me to get a Serial connection, but I’m still able to enter DFU-mode and upload code.

No Serial communication makes it a little harder for me to debug my code, but I’m started to debug with UPD. Is there another way to debug easily? Maybe through NetBaens, like the way you can debug a PIC microprocessor?

Can it even be the cables? Is there ANY difference on micro-USB cables, I’ve noticed that it isn’t all cables that fits easily into the core, and it looks like there i missing some connectors in the cable i have from my Samsung smartphone.
I have also tried to do a factory-reset with no effects.
I am still able to see COM-ports from my Arduino, and i have no other external devices plunged into may computer, but is i my computer, the cables or the core there is the reason for my trouble?
I haven’t even changed the cable very many times before it stopped working, so i doesn’t thing it’s the connector/(plug?).

Thank in advance!

Hi @Dave,

Yes, I can login and do spark help, but spark setup throws the errors. I’ve tried both node command prompt and windows command prompt both with and without admin privileges. I’m running Windows 7 x64 and node v0.10.28

I tried to install the dfu driver to see if that would help (https://community.spark.io/t/tutorial-installing-dfu-driver-on-windows/3518) but it did not appear, but also is not trusted by antivirus programs it seems…

Hi @AlexMiller,

Can you confirm your Core has a COM port registered in the windows device manager? You also mentioned:

did you do that over serial with the CLI? I’m a bit confused by the serial error if the other stuff is working? Can you include the full output of the command up to the error you’re seeing?

Thanks,
David

Hi @simoher,

Sorry about the slow reply! It sounds like you need the virtual com port driver for Windows. There’s a guide for installing that here: http://docs.spark.io/connect/#connecting-your-core-connect-over-usb ( https://s3.amazonaws.com/spark-website/Spark.zip

I hope that helps!

Thanks,
David