Stuck installing spark-cli any pointers would be great


I haven’t done anything with my cores for a while and as I have 2 weeks off work I decided to work on a project thats been in my mind for ages.

In order to get debugging I’m trying to get data sent out to the serial monitor, however I can’t see any new serial devices when I plug a core in like before, even with the new Spark Dev app.

Reading through some posts it looked like I need to install spark-cli to get it working, would I be correct in thinking that?

Anyway, Node.js installed fine.

$ npm install -g spark-cli

^ this did not appear to work as it was giving lots of errors, warnings, etc, so reading on more forum posts it suggested trying without the -g flag. Output from that seemed to do the trick.

Ok, next:

$ spark cloud login

Resulted in

-bash: cloud: command not found

So tried to update my .bash_profile. I think this is where I’m stuck.

What files should be in the directory that the path is pointing to?? I took a look at:


and there was one folder, “1.0.0”, in that was “package”, inside that was “package.tgz”, and a folder “package” containing “package.json”.

I extracted the package file, into the “package” folder and updated the “.bash_path” file to point to it.

Am I even going in the right direction?

Any help is much appreciated.


you will need Serial.begin(xxxxxxxx) in your setup() for the firmware you use in order to see a serial device. Spark-cli is not required. :slight_smile:

Use sudo npm install -g spark-cli --verbose

To login, try spark login

Thanks for your help,

spark-cli install did a whole bunch of stuff it wasn’t doing before during the install, so it looks like it went ok, strangely “spark” command still not found, I’ll take a look a that later though.

It looks like it wasn’t showing up in the serial monitor as Spark Dev wasn’t flashing the firmware.

Now I’m back on track, thanks again.

1 Like