Spark core list empty in the CLI

My SparkCore doesn’t show up on the list of available cores in the Spark CLI. It is connected to my account and I can use the tinker app perfectly fine on my phone as well as flash tinker to my SparkCore through the CLI.

Any thoughts on what might be happening. (I am not sure what more info you guys may need but just ask and I will try to provide!)

Thank you!!!

Try logging out and in again? It might be a typo ;D

I did give that a try and it didn’t work. I also tried fully unistalling node.js and re installing it…

I’m pretty new to all of this (only have a few months of Arduino coding under my belt) so I am sure I am missing something silly…

Can you login with the same credentials on the WEB IDE and check the cores tab?

Yeah and my core shows up there…

I tried logging out on the CLI again and remove the access_token and when attempting to do that there is an error message that pops up:

error removing token: Error: socket hang up.

Would that have anything to do with it?

Weird… can you login spark-cli again and check?

I will try: "spark flash core_name tinker" to see if I can reach the core by flashing the tinker app

I just logged back in and I can flash the tinker app through the CLI which seems odd to me… It can access the core but is unable to recognize it on the list?

I figured it out… I was using spark core list not spark list… I have access to it now… :blush:

Thank you for your help


It should work. Can you try spark --version?

Try updating to the latest with npm update -g spark-cli :wink:

Have fun!

1 Like