API / Cloud down?

Hi folks,

my Core stops working today.
I have checked spark status and everything should be up and running, but I cannot get values from the cloud and functions registered also do not work.
I have reset my AccessToken and try it once again, but nothing. Code works now for >2month. So there should be no issue.

https://api.spark.io/v1/devices/CORID/?access_token=ACCESSTOKEN

Gives me after quite a while following result:

{
  "id": "COREID",
  "name": "CORENAME",
  "connected": false,
  "variables": null,
  "functions": null,
  "cc3000_patch_version": "1.29"
}

@clyde, can you try using tinker?

Things seem ok on my side :wink:

  • Tinker “Error connecting to the core”
  • CloudIDE “Flash unsuccessful”

It should work, I can see the core in my routers DHCP Table. I don´t want to reset it, because my WiFi password is >32 it works only with spark-cli and that is really circumstantial. And again it worked over >2month without any problems. No changes on my side… just stops working.

Do you have Spark-cli installed?

Try to see if the core is listed first :wink: Or perform a factory reset and see if factory tinker works fine

Just to be sure–in your example above COREID is long hex number, CORENAME is the name you gave your core, and ACCESSTOKEN is a long hex number, right?

In other words, you have edited the post above just to protect your privacy but in the real stuff you have real numbers.

You would be surprised how often I have to ask this!

@bko: No need to explain :slight_smile: I know those mistakes. But sadly it is only for privacy reasons.

@kennethlimcp: Not a really good option, as I said before. This is same as “my car stops working and I try to change the engine”. :wink: Don´t get me wrong but I want to knwo whats happening.

I have exactly the same problem - core has worked pretty much perfectly 24/7 for the last couple of months. Now I get the same message as you do

"id": "xxxxxxxxxxxxxxxxxxxxxxxxx",
  "name": "BraviaTV",
  "connected": false,
  "variables": null,
  "functions": null,
  "cc3000_patch_version": "1.29"

led is ‘breathing’ as normal, and is definitely connected to my network, as it is still communicating with another device on the local network, (pushing its status to my home automation controller when I turn my tv on or off, )but seemingly not reachable via api.spark

It’s inside my TV and I’d really rather not take it apart if it’s not a problem at my end.

Any ideas anyone?

@Dave is looking into this right now so let’s wait for news :wink:

1 Like

Hey All!

Sorry, I was off duty this morning but I’m seeing this now. Can you PM me your device id that is malfunctioning and I’ll check it out? I’ll tweak some things from my end and see if I can fix the issue.

Thanks,
David

Hey All!

It looks like there was a brief window last night where there were some issues with one of our databases. Although things self-healed for most devices, some devices got caught in a ghosted state. I restarted some things internally and it looks like the error counts are back to normal. Sorry about the delay! We have a few people on duty today for the holiday, but the error counts were low enough that it didn’t seem like an anomaly.

I’ll look into why it didn’t fully self-heal for all devices so we can avoid that in the future.

Thanks,
David

3 Likes