API to Core response time [patched]

I don t know why… Until yesterday all worked fine for me with the core.
Today unfortunately, I have many Problems.
At the beginning when I tried to put the firmware on the core, I received a message, that there was a problem. After trying a few minutes, it worked. After that moment, I could not send any commands via cURL. I received a message that there is not such a function on my core. The core si breathing slow cyan all the time.
On the spark website, I looked under the page where my Core is listened. But there was also an error message, that there is no Core.
I tried a factory reset. After the reset, the core was visible. But I could not load any of my programs. I don t know how many resets I did. Than I removed the core completely from the cloud. I tried to claim my core more than 10 times. (There was always an error that I can`t claim the core). Than unexpected, I was able to claim the core. But I have still the same problems. I tried to put an example code on my spark. But also in this case nothing is working as I expect.
Do someone have the same problems at time?

i have also been having sporadic problems all evening today - during daytime everything worked quite fine but now the core is disconnecting from the cloud almost immediately after bootup, and at some point the core was looping through flashing red -> cyan -> red … even the web ide had some hiccups (404s while verifying etc.), and then it seemed from status.spark.io that they were having problems with heroku. so… i hope this is just some problem with the cloud services and that it is fixed soon :slight_smile:

@triplea I too am having these exact same symptoms as of today. I finally got the cloud to see my core connected after many resets, but still all timeouts executing any curl commands to use functions. I have not had this problem until today.

I checked the services status and it is all green…

Hello guys, just wanted to pop by and say that I have @pinged Spark and see if they noticed anything unusual with the cloud services.

Monitoring is in place and should have alerted them if something cropped out.

It’s probably too many enthusiastic users like you guys getting more and more cores online that the service might be slightly overwhelmed? :smiley:

Some nice person responded to me on twitter to check my access token. Looks like mine is still valid.

  "access_token": "XXX",
  "token_type": "bearer",
  "expires_in": 7776000

Still can’t get my core… and I am back to not connected. A call to https://api.spark.io/v1/devices/48ff70065067555035541387/ shows

"id": "48ff70065067555035541387",
"name": "megastatz2_sfid",
"connected": false,
"variables": null,
"functions": null,
"cc3000_patch_version": "1.28"

Even though I am breathing cyan and reset a few times.

I am getting to the could service via curl just fine, I tried messing up my access_token and it responds immediately with bad token.

Can you simply flash firmware via OTA to check if it’s indeed connected to the cloud?

So I tried to flash it and it won’t. I hit reset and then as soon as it breaths cyan, quickly flashed it successfully. All curl commands still timing out.

Do you have spark-cli installed? Seems like your core is not behaving properly though.

What curl commands are you running?

I just fired up my core and checked that the services are working fine…

this is the command - I don’t have the spark-cli

curl https://api.spark.io/v1/devices/48ff70065067555035541387/setemp -d access_token=XXXX -d “args=750”

also if I go to https://api.spark.io/v1/devices/48ff70065067555035541387/?access_token=XXX in a browser I get the I am not connected status.

I can only flash OTA as stated above if I hit the reset button and do it within seconds of the flash.

Hmm…It sounds like some code issue causing the core to drop connection to the cloud.

I know you managed to get it working but… maybe you can paste the code here and we can see what’s going on.


I have been having a similar issue tonight. Often after flashing code I get the breathing cyan but am not connected to the cloud. Resetting it will sometimes connect. Once connected it seems stable but after flashing again it sometimes doesn’t reconnect.

I’m sorry to hear that guys.

Have once again posted updates to the Spark team and see if they can figure out what might be causing the issue.

I don’t think it’s affecting a mass group of cores though. Currently flashing tinker to my core via OTA and see if the same behavior arises.


Hmm…tinker works fine for me…

Ah ok i have the same issue now!

It seems like the same binary file was flashed instead though the core was changed…

I flash Tinker and while it connects to the wifi and the cloud quickly, once I have breathing cyan I am offline.

Resetting several times with the same quick connects and finally it will actually connect. At which point either my program or tinker will seem to work well enough (at least for a while).

1 Like

Thanks guys. I have managed to replicate the issue and share the Test case with the Spark team.

Will update this thread the moment i hear some updates. :wink:

1.) Seems like the core becomes declared as offline after some a brief moment of connection

2.) The functions and variables become unlisted after awhile


@kennethlimcp awesome. Just to note, maybe it is something recently introduced? I definitely did not have this problem last night.

Thanks Again

I just think that there’s some intermittent due to too much awesome cores breathing cyan! :smiley:

See the comments for 6th October here: http://status.spark.io

Hey just a quick note in case it helps. I am occasionally getting a 502 Bad Gateway on the requests now.

1 Like

Further documenting the number of affected customers, I’ve also experienced inability to flash my device today. Over approximately the last 8 hours (Oct 8, 18:00 - Oct 9, 02:00 UTC), it has worked intermittently, but much more frequently the web IDE has failed with the following sequence of messages in the lower left hand corner of the screen:

  1. “Flashing code…if it does not flash magenta, verify your code and try again.”
  2. “The request seems to take longer than usual. Please be patient…”
  3. “The server has failed to process the request on time. Please try again.”
  4. “Ready.”

If I’m not paying attention, the “Ready” message makes me think the flash was successful, but no update was provided to the core.


1 Like

Hey All,

Sorry about these issues you’re seeing today! We made some changes to the production cloud today to ramp up the number of servers we’re running, and I think you might be seeing issues as your cores pop around the various servers. I will look into this and get it fixed as soon as possible.


You willl be able to see the updates here: http://status.spark.io

New Incident Status: Identified
We made some changes to the number of servers we're running, and we're hearing reports of some core status issues. We're looking into it and we'll keep you posted. Thanks!