[SOLVED]Connecting a sparkio


I have had my spark for quite a while working perfectly. I use it to open and close my gate remotely.

I recently switched routers and now I am unable to get my spark to connect at all.
I have tried the spark app and the command prompts and putty all to no avail.

Are there any suggestions to put me on the right track as I only get fast flashing cyan.

@jcdude, can you supply details on your new router? Is the 2.4GHz SSID different from the 5GHz SSID for example?

Dont think it has 5ghz


This is my other router that I have also had no luck connecting to

@jcdude, how is the wireless security setup? Is it exactgly as in the manul setup?

@jcdude, can you show more on the wireless security settings? How long is the password and is it alphanumeric?

Example password test87873434

@jcdude, TCP port 5683 (COAP) needs to be open to allow for a Particle Cloud connection.

1 Like

Still no connection.

I even turned the firewall off with no luck

Ping @kennethlimcp, @ScruffR

I’ll try to catch up on the thread and see if I can find something

What’s the led colour on the device?

When you say sparkio / spark, are you refering to the Spark Core (vs. Photon of the same company/different brand)?
Since all the common suspects were eliminated by @peekay123 already, can you first try to wipe the WiFi credentials from your device by holding down the MODE button for 10+ seconds till the RGB quickly flashes blue.
Then try to reenter your credentials (or even try open WiFi and firewall off temporarily).
If this doesn’t work (and you are on a Core) try a factory reset, apply a CC3000 update (how to can be found via forum search) and reenter credentials again.

Just to make sure:
You have not set a static IP on your device that doesn’t belong to your new subnet?
You haven’t set MAC filtering on your router?
Your device is definetly in range? (new router might have shorter range)
You have no blanks in your SSID/password? (these are allowed, but might be overlooked when reentering credentials ;-))
Increase max clients count on your router.
(Remove bandwidth limiting. Or have you got a shared uplink?)

1 Like

flashing fast cyan

I have tried turning the firewall off. But what baffles me is that the settings on the one router that I have tried to connect to are exactly the same as they used to be and I cannot connect to it.

Is there any test I can run from my computer to see if I can get through to the cloud

On Linux/OSX you might be able to get hold of a package called coaping

On Windows I don’t know of anything similar, but you could use something like telnet to open a connection on that port and see if something comes back.

If you try telnet 5683 you should receive a bunch of random characters - if not your CoAP doesn’t get through.

But Paul’s suggestion below goes in line with what I said above. Give it a try!

@jcdude, I just had a Core do the same thing. I ended up flashing the cc3000 patch several times and different versions. I suggest doing the following using CLI (assuming you have it installed):

particle flash --factory tinker
particle flash --usb cc3000
particle flash --usb tinker

The first command updates the factory reset code. The second flashes the cc3000 update and should finish in DFU (flashing yellow) mode. The last flashes the tinker code over.

Try the first two, then do a factory reset which will wipe all your wifi creds. Then use CLI or terminal to setup new wifi creds and see if it connects then.

1 Like

Thanks I will give this a go and get back to you