Enterprise Network Issue

Hello, I’m having trouble trying to connect to my Spark to the cloud; I’m getting continuous cyan flashing with the occasional two red flashes (Connection failure due to bad internet connection).

It goes through the normal sequence but fails to breath cyan, although it apparels to be connected to Wi-Fi, as our IT feller can see it on his connection software (Aerohive).
He has opened up Port 5683 on both the Wi-Fi firewall and the main company firewall, but this has not fixed the issue. we don’t have a captive portal.

I guess my question is any ideas? Are there any other ports that we could open?
(Note: Company policy prevents a complete firewall deactivation)
I need to get these connected as we will be placing an order for a few hundred sparks once we get it sorted

Many Thanks for your help,

1 Like

I’m sure somebody here will get you up and running soon.

I’m just curious about how you plan to put a few hundred Sparks to good use?

A company wide Energy management System/Review, Using ammeters, flow meters, thermometers on key electricity supply lines and heating fluid pipes coming into all campus buildings/floors and departments.
all talking back to the server with Spark Cores

Should be a fun project!



Hmm, we have an AeroHive setup here at Spark HQ actually, so I know it can be done. Maybe try clearing the WiFi profiles on the core in case it’s connecting to an old / wrong AP, and Can you open a connection to the cloud servers ( ) just from a computer on that wifi network? Are you guys able to generate a packet capture of the core during the handshake?

It sounds like it’s connecting, but can you say what security mode / channel you’re connecting on?


We tried to Ping that IP address from both inside and outside our network, but it can not be found.
Any chance there is a typo?

Hmm, I think that’s the one, can you try opening that port instead of pinging it?

telnet 5683

I couldn’t get my Spark setup with TI’s smart config on our Cisco Meraki network either (it’s a reasonably common enterprise solution) and the symptoms were similar to yours. However, if I set up the wifi-credentials using serial instead the Spark worked just fine. Maybe that’s something you could try?

@nmattisson so the core was blinking blue throughout when you sent credentials using the TI smart config app.

Just to check, did you use ‘sparkdevices2013’ for the aes?

@kennethlimcp Yes, I tried using the Spark app, and the TI app, following the instructions in the Spark documentation — but ultimately had to resort to serial.

I think there’s some issue with enterprise network. Read it somewhere else.

If only it became stable blue then things would have been different!

At least your :spark: core is breathing now :slight_smile: