Setup help! Can't find solution!

Okay here’s the problem: my internet button refuses to connect to my computer or my phone. I have tried all the methods that the website addresses, and it still won’t work. It’s so frustrating.

I plug in the internet button. It starts blinking blue. I open the app, and it tells me to select the photon in my wifi settings. I go to my wifi settings. The photon network is visible. I click on the network, and it gives me the “connecting” symbol. I then get a notification from the app saying that it’s connected. I hit the notification, and the app opens. Then nothing happens. I wait and I wait and I wait… and nothing. I go back to the wifi settings and it shows that it’s still connecting. Perpetually connecting. It never actually connects. Then, I tried it on my computer. I used the web connector tool. I followed the steps, found the photon network, clicked on it, and then the button flashed its LEDs in rainbow colors. But it still wouldn’t register on the installer website. The colors remained illuminated, but the website didn’t seem to think it was connected. So I unplugged the internet button, plugged it back in, and tried again. This time, no rainbow. Just perpetually flashing blue. So then I tried the setup using the command prompt. This is what happens.

It does this forever. Once, it found the network. It asked me if I wanted to perform the setup with my photon. I said yes. Nothing happened after that.

I can’t figure this out. I’ve spent hours searching the internet and trying and re-trying everything, and it’s just not working. It’s so frustrating. I really want to learn how to do this but I keep getting more and more discouraged by the lack of cooperation I’m getting from this thing. Someone please help me.

Just to recap, here’s my problem:

My Internet Button will not connect to my devices.

I’ve no idea if the thing will connect to the internet once it’s connected to my device. I haven’t gotten that far.

Please help. I’m so done.

Sorry it’s been so difficult so far, it really shouldn’t be that way.
Using the CLI, could you try particle doctor, and have it update your device to the latest system firmware. Then try the regular setup methods again, or give particle serial wifi a shot, which should allow you to give it the credentials.
If the latter works, the device will be unclaimed, which you can claim using the CLI as well particle device add <ID>, inserting the ID you got from Particle identify.

Identify only works in listening mode, and claiming only in breathing cyan mode.


You’re a gift upon this earth. Thank you so much. All I had to do was update the firmware. I had tried that last night but I was so tired and frustrated that I did it wrong/didn’t have the patience to let it do its job. It seems to be working now. Again, thank you!!!