Photon board not connecting to internet or cloud

So I’m using the photon board for a project for school. It was working fine for the past few weeks but then it wouldn’t connect to cloud and would blink cyan, breathe orange twice, blink green, the go back to blinking cyan. I found a thread that said to do the following to fix it in the CLI:
in DFU mode

  • particle keys doctor
    in DFU mode
  • particle keys server

I did that, but it didn’t fix the problem only changed it. Now I can’t connect to internet at all. I get this error when running particle setup:

I found another thread that said to do the following:
in DFU:

  • particle update
    in DFU:
  • particle keys doctor
    in DFU
  • particle flash --usb tinker
    in listening mode:
    copy device id
    particle serial wifi
    particle device add
    particle setup

This also didn’t work. I’m at my wits end trying to trouble shoot this. Please help!!

What is it doing after that?
What’s the current state of the device (LED)?
particle doctor is another option you could try.

No change, It currently just continues to blink green even after trying particle setup.

Update, tried particle doctor, no change. Still can’t connect to wifi. Still blinking green really fast after running particle setup.

According to the tutorials on Device Modes and status LED, 2 orange blinks indicates “Could not reach the internet”.

Are you running this at school or at home? Did anything change in either networking environment? Could it be possible that the connection to the Particle servers is being blocked? Or has the port been blocked? Can you test on another hot-spot?

When it was breathing orange it was on a hotspot from a smartphone. It has since stopped doing that since I tried connecting to my home wifi. Which is still what I am currently trying to connect to. As of yet still can’t connect to my home internet at all.

Update: when I run particle setup the on-board LED blinks green really fast (faster than normal) while attempting to connect to internet, then returns to listening mode. This pattern repeats every time I try to run particle setup.

Rapid blinking green indicates an attemt to connect to the local WiFi and acquire an IP address. If this doesn’t succeed and there are no other valid WiFi credentials then the device will fall back into Listening Mode.
This indicates your WiFi credentials are not accepted. Reasons can be that your submitted WiFi creds are wrong or your AP doesn’t accept the devices (e.g. due to MAC address filter, static IP collision, captive portal, …)

We don’t know anything about your network, so it’s hard to be sure what causes it.

1 Like

I tried connecting to my phone hotspot and it works now, but it still won’t connect to my home wifi. What are the standards around what wifi the board will connect to?

The docs do tell
https://docs.particle.io/quickstart/photon/

If your network adheres to the above you should have little problem.
However, as network owner you could still do things that would prevent a connection even then - e.g. MAC filtering, limited DHCP IP pool, …
And with some extra effort you can also connect to WPA Enterprise networks, but that doesn’t seem to apply to your use-case.