[RESOLVED] Manual firmware upgrade failure

Tried doing the deep update since I messed up and unclaimed device when I had corrupted firmware (not the best call). I have attempted trying to claim the device and had managed to get it connected to my network, but was never able to claim the device via app, Web IDE or the CLI.

So i tried doing the deep update, but ran into this issue:

It says it can’t find the CC3000 firmware. Not sure why. However, now the board is blinking cyan after I ran it.

Then I tried connecting again by holding down the setup button and the LED was blinking blue. But it fails to connect to the cloud, as it says on the CLI.

You are trying to apply a CC3000 update on a Photon which hasn’t got that chip on board.

Can you explain or even better provide a video of the colors codes you see on the RGB LED?

Sorry, I didn’t know that. I will try to be more detailed.

When I plug in my Photon board, the LED blinks green for a few moments before changing to blinking cyan. However, in a few moments the LED changes to blinking red/yellow (almost looks like DFU mode) for a few seconds. then switches to blinking green and then blinking cyan (the pattern repeats).

This indicates that the WiFi connection is OK, but the cloud handshake does not work.

First try to update the device in DFU Mode

particle update

If this doesn’t change anything try

particle keys server
particle keys doctor <yourDeviceID>

received this error when I tried particle keys doctor command, I used the Hex string for the device ID

The other two commands worked. Is the Device ID something else?

I see, you seem to miss the OpenSSL tools.
Have you installed CLI via npm or the CLI Installer?

If you had used npm I’d suggest to do

npm uninstall -g particle-cli

and then use the installer (with all tools selected)
https://binaries.particle.io/cli/installer/windows/ParticleCLISetup.exe

You may need to restart Windows to get your PATH set up right after install.

Hmm, I used the installer and remember openSSL being selected. Should I still uninstall the CLI and then run the installer again?

Did you have CLI installed via npm before using the installer?

However, if you had OpenSSL ticked, you can manually add it to your PATH (once you found where it got installed :wink: )

Tried it, different error:

Maybe try executing that command from a directory that isn’t a possibly write protected system directory.
Try to change into your Temp or user directory, but not C:\WINDOWS\system32

1 Like

So I was successfully able to make the keys. But it is still blinking cyan rapidly and yellow/red twice. This pattern repeats every 20 seconds (i timed it).

Then I attempted particle update and reflashing Tinker to see what happens.

Both were successful, but then when i wanted to manually connect to the WiFi network, it stays at “Attempting to configure WiFi on COM3” for at least 15mins.

Also it still says at the blinking cyan and the twice red and yellow in that 20s pattern.

What else should I try?

Ah, I think I have the same problem as this post:

I need to figure out how to clear my static IP settings.

You need to flash a “reset sketch” like this

SYSTEM_MODE(SEMI_AUTOMATIC)
void setup() {
  WiFi.on();
  WiFi.useDynamicIP();
  Particle.process();
  delay(500);
  Particle.process();
  Particle.connect();
}

Update:

I just saw you had asked that in the other thread too and already got a similar answer - how we like spending time twice.

2 Likes

Apologies, I thought I had posted that it was functional again on this post. Thank you again for helping out!

2 Likes