Photon Problems With Keys and Open SSL


#1

Photon is blinking blue and red and can’t connect to cloud. It used to connect just fine. Been trying to fix it for 3 days with no luck. Got angry and unclaimed device and now I can’t claim it again.
But it’s in DFU mode.

I tried updating and it said “device is ready for system update”. It says it completed successfully, but no matter how many times I run ‘particle update’ it says the same things, ready for update and completed successfully. After searching in the forums I read it could be a corrupt key and that I should create a new key. But when I run ‘particle keys new’ it shows this:


I read that means no Open SSL? But when I installed Particle CLI, it showed it installed Open SSL and there is a folder in C:\ named ‘OpenSSL-Win32’. And I created a path: C:\openssl\bin

I tried running ‘particle keys doctor’ and got this:

Trying to save key shows:


Here’s something else I tried:

And trying the cloud_public.der returned:

Device Manager shows: Photon (Com 1) under Ports. I did a Update Driver, no change. When it’s in DFU mode, Device Manager shows it under: libusbk USB Device, Photon DFU mode.
And if it helps, I’ve got Windows 10.

Any other suggestions? Personally, I think this photon’s had it.


#2

Blinking blue means Listening mode. Either you don’t have WiFi credentials or somehow entered the mode. That does not actual point to a keys issue.

You will want to use the Windows install found here: https://docs.particle.io/guide/tools-and-features/cli/photon/#installing

It will install other software such openSSL that is missing.


#3

I’ve done that, but I just tried it again with no luck–now it’s blinking fast cyan with an occasional red every now and then. I know the wifi credentials are right because I have another photon that connects with no problem. The only difference I’ve noticed is when I set up the ‘working’ photon, it gave security type option for WPA2 and a drop down list for encryption method which is AES. This ‘bad’ photon won’t give me that option.


#4

The last tip at the end should solve the missing openssl issue for you. but here are the whole instructions:

Put the Photon into Listening mode (blinking blue) by holding down SETUP until it blinks blue. Then issue the CLI command:

particle identify

Save the Device ID; you’ll need it later.

Then put the Photon in DFU mode by holding down both the RESET and SETUP buttons, releasing RESET and continuing to hold down SETUP until it blinks yellow and issue the commands below, in order.

particle keys server
particle keys doctor YOUR_DEVICE_ID

If you get this error under Windows:

'openssl' is not recognized as an internal or external command, operable program or batch file.

and you have used the CLI installer as described above, it may work if you do:

cd c:\OpenSSL-Win32\bin
particle keys doctor YOUR_DEVICE_ID

There are additional tips for a missing openssl error on this page, including tips for Mac OS X and Linux.


#5

Wow! It’s a miracle!! Thank you, thank you! I’ve been 3-4 days trying to fix it. And you did it in less than an hour!
The day is now looking better!