Protected network blocking Photon and hot spot not working

I read in the docs that the Photon may not be able to connect to certain corporate networks and it looks like I have that situation. Before I go beg to change whatever is blocking my Photon (unlikely to be granted), I thought of using my cell phone as a hot spot. That’s not working either.
I read an old thread about this, but I got lost in the resolution. However, I think in that case the WiFI was not blocking the Photon.

I have a Galaxy S9 and the Photon runs 0.6.3.
I put the Photon in setup mode, blinking blue. I use the Particle app on my phone to connect to the Photon’s wifi. It tries to connect, but eventually it times out. I get an error pop up saying to retry, but no explanation about the error.
I turned on Mobile Hotspot and Tethering on my phone, but I suspect it still tries to use the WiFi to get to the internet. I can’t turn off the WiFi on the phone because then it can’t talk to the Photon.

I tried this with a BluzDK and it works great using the Bluz Gateway app. I turn off the WiFi and then pair the BluzDK. I can then use cell data to put the BluzDK online. If I keep the WiFi on, the gateway app must get blocked too because the BluzDK does not go online.
It seems like I need a gateway for the Photon and the Particle app does not provide this function.
Searching for Photon gateway did not turn up anything interesting.
Has anyone tried this before?

Thanks for reading,

I’m pretty sure you can’t simultaneously create a Hotspot and be connected to wifi using your phone. If you have another phone, you can use that configure the photon over SoftAP. Alternatively, use the CLI over serial.

1 Like

Now that I think about it I suspect the problem is with configuring the Photon’s credentials. The SoftAP must not be working.
I can see the Photon’s ssid, but the phone fails to connect to it. I don’t think at that step in the process the phone has switched to the other network yet.

Android phones don’t let you simultaneously broadcast a hotspot and connect to wifi. You’ll need a second device, as @Moors7 said.

1 Like

Thanks for the replies
It turns out the problem is with the Particle app running on my phone. I can communicate with my devices, but I can’t connect to the photon’s wifi.
I tried an iPad and I was able to setup wifi credentials. So, looks like I need to research a different issue.

While the iPad did the softAP setup, I was able to use my phone’s hot spot. Once I get back to the protected network I should be fine.
Thanks for the tip!

@Pescatore, I think you missed the point SEVERAL members posted. This is NOT a problem with the Particle app but a limitation of the way phone hotspots work. If members are posting valuable and helpful comments, please take the time to read them.


You were able to set it up using your Ipad with the phones hotspot because you weren’t trying to do both simultaneously with the same device. The Ipad was connecting to the softAP, and connecting the photon to your phones Wi-Fi. That works exactly as expected, there is no issue, but I’m glad to see it up and running.

1 Like

Thanks for the kind follow up @Mjones . I did read the posts and understood the conflict.
I really had an issue and it was the Photon. I could not set any wifi credentials with my phone,
but I could with an Ipad. This was with hot spot off and on an open network.
I was blaming the Android version of the Particle app.
Even with new credentials, the Photon was connecting to the cloud and periodically went offline.
I ran particle doctor and finally had a steady connection. Now I can also set credentials with my phone.

Anyway, I still had problems on the protected network. The reason is that my phone was staying
connecting to the network. So, first I had to disable automatic reconnect. Then, turn off the wifi and
turn it back on to disconnect from that network. Now I turned on the hot spot.
Once I reset the Photon, it found the hot spot and went online.
BTW: I ended up setting the hot spot credentials with CLI. Thanks @Moors7.