Cannot Get Photon to Connect to Wifi Inside Apartment Complex Network

I cannot seem to get my Photon connecting to my wifi.

First, I tried using the android app. However, when I tried setting up a new Photon device and clicked the “ready” button, it says “No Photon devices found.”

So, I decided to connect over USB instead on Windows 10. I followed this excellent tutorial here: [Particle Official] Windows 10 Full CLI and DFU Setup. I was able to update the firmware on the device successfully (at least it said so), though I am not sure what version the firmware is at.

Then, I tried to do particle setup CLI command to connect my particle to my wifi. I connect to the Particle’s wifi hotspot, then when I manually try to enter in my wifi info, I get a repeating loop of “Obtaining device information…” and nothing happens. It’s the same thing with the particle wireless list command.

Note that particle identify, particle serial list, and particle serial wifi all show no devices attached, which is weird because I was apparently able to update it in DFU mode.

My Photon is blinking blue and I have not seen any weird LED statuses. I can see the device in Device Manager as “Photon with WiFi” under Universal Serial Bus devices. In DFU mode, it will say “Photon DFU Mode.” The CLI can see the Photon’s wifi network during particle setup, and my computer can connect to it for the setup, but I just can’t get past the “Obtaining device information…” part.

I wonder if things are messed up because I am in a student housing complex where the internet is distributed to the whole complex, and thus there is probably a router that is upstream from mine.

Any help? I’ve tried reading all the other posts, but didn’t find a fix for this.Thanks.

So, I finally connected to my Photon! I think it was my apartment internet setup. The guide did say the wifi must not be “behind a hard firewall or Enterprise network.”

For posterity’s sake, here is how I got around the problem and finally connected to my photon inside an apartment complex internet network:

I simply created a mobile wifi hotspot using my android phone. I then connected my computer to the mobile wifi hotspot and uplugged my apartment ethernet connection. Then I manually entered in my SSID, password, and security for the hotspot. I was quickly rewarded with the “Configuration complete! You’ve just won the internet” message.

Hope this helps some others!

…Actually, I never got it to connect to my wifi in my apartment internet network. It just won’t work. Even after initially registering my device to the cloud, going back to the apartment internet network still doesn’t work. So I will have to be content with turning on my mobile hotspot each time I want my Photon to connect to the cloud.

I think I ran into a similar problem when I tried to host a website in my apartment one time. Without access to what ports are being forwarded and what IP addresses are where, you can’t have a service that lives behind a router that you don’t control… right?

So what is fundamentally different about my mobile wifi hotspot that allows it to work, exactly?

So, I was finally able to get the Photon to work inside my apartment’s network. I recently bought a TPLink/Google OnHub router, and it has no trouble working with the Photon. I was anticipating that maybe double NAT was the cause of connection problems with my previous router, and I would need to turn the OnHub into a bridge, but it turns out it works fine with default settings.

TLDR: I guess using a 4-year old router (Medialink MWN-WAPR150N) is not the best idea when trying to connect to a Photon.

There were some other reports about some “brand” routers that just didn’t want to work either - but currently there seems to be no known reason why.
Hence it’s difficult for Particle to fix this without getting hold of the actual problem.

1 Like