Problems getting Boron connected (3rd pary SIM)


Thanks for the info. Im having a bit of a bad start with the board. I did at some point get a connection using the built in sim not 3rd party after my sos+10 issues. I think This was after doing a: particle update. It all sprung into life. Unfortunately Ive messed something up since and now can’t get it back connected. Also through CLI I can’t identify or list. Just times out.
When ever I use the phone app it pairs, but then gets stuck in the do you want to use in mesh network or not.
Tried allsorts of reboots, device, laptop, phone, holding mode buttons until white etc.
Any thoughts?
Thanks in advance.

I have moved your “new” issue to a separate thread to avoid thread-jacking the original :wink:

Just to clarify, you are not seeing the SOS+10 anymore, right?
You might have run into a bootloader issue and/or some unfinished business with setup.
To get things sorted again I’d do

  • remove the 3rd party SIM
  • reset the device by powering it up and then press/hold MODE for 10+ seconds till the RGB quickly flashes blue
  • run particle serial inspect and post the output here

Yes correct no more SOS+10. After following your last instructions the board returns to blue flashing - listening mode.
The particle serial inspect times out. Like the other serial commands such as particle serial identify. (Serial timed out).

That could also be a driver issue. Are you on Windows?

Hi, I was using a Mac. Today I have continued bashing my head with windows… but have a least made some progress. I repeatedly re tried the fw flashes - tinker, 1.2.1, tinker then boot load without success, couldn’t get any serial data information. I then rolled back to hybrid 0.9.0. created my 3rdpartysim.cpp file and flashed that over, then flashed tinker0.09.0. Hey presto it connected using the 3rd party sim and I think at that stage I could get particle identify and particle serial inspect information from the boron.
Ive since put across the standard blink an LED program and the web-connected LED. But I have lost serial connection, as in I can no longer get identify or serial inspect. Is this because the user file/code doesn’t have serial begin included? (probably a noob question)

Ive also noticed I can control the web-connect led from the console, Signal the device from the web IDE etc. But if no changes/traffic is made after 1 min i can no longer function on & off the led via console. ping the device, signal it etc.
Could this be something to do with the user programme/fw? it’s as though the device goes to sleep.
Many thanks

You need to set Particle.keepAlive() since 3rd party MVPN providers usually close the UDP window much quicker than the Particel MVPNs (23 minutes).

Nope, when the device is put in Listening Mode (blinking blue) the USB Serial interface would be pulled up by that.