Connection Issues With Activating Recent (Nov 2019) Borons

boron
Tags: #<Tag:0x00007fe22078f2f8>

#1

Just wondering if anyone else has attempted to set up new 2G/3G Borons recently (Nov 2019). I’ve set up a bunch of Borons (both LTE-M and 2G/3G) before and they worked fine and still continue to work fine.

However recently I cracked open some new kits and even a x50 tray of Boron 2G/3G and tried setting up 3-5 devices with no luck. I’ve managed to register and activate the SIMs to my account but the Borons would never connect successfully (i.e. blink green forever)

Somethings to note:

  • All devices were updated via particle update to OS 1.4.2
  • Tinker app was also reinstalled via particle flash --usb tinker
  • SIMs were all actvated sucessfully (i.e. got e-mail confirmation)
  • Antennas and batteries were plugged in
  • I’ve waited a few hours for them to connect, even waited a couple of days incase the SIM carrier takes awhile to activate the SIMs
  • Yes I do have cell connection, powered up a previously set up Boron 2G/3G device and it connects within a few seconsd of booting up

I’ve also contacted particle with Boron debug logs. Waiting to hear back. But in the mean time, just wondering if its just me.


#2

Just to supplement @slacker89’s ask - the affected Borons provide the following error code:

[hal] INFO: Using external Nano SIM card
[hal] ERROR: Failed to perform early initialization

and

[ncp.at] TRACE: > AT+CPIN?
[ncp.at] TRACE: < ERROR

which points to a SIM (in this instance, specifically a nanoSIM issue). I personally have never seen this error before (not CME ERROR: SIM NOT INSERTED, just ERROR) and we’re working to get this fixed ASAP.


#3

@marekparticle I also e-mail you with more details but just a quick update from the post.

So the Boron devices that I am trying to get working are all brand new so they shouldn’t be pointing to the nano some. I re-flashed firmware to clear credietials etc… to force the device back onto the internal SIM. However, upon flashing the cloud debug binary (https://github.com/rickkas7/boron-clouddebug/blob/master/boron.bin) the device went back to using the external SIM. Steps are as follows:

  • Update device via particle update
  • Flash boron.bin from cloud debug repo
  • On first run it seems to run fine using the nano sim
  • Reboot the device and then watch the test logs, the device apparently went back to the external SIM.

I’ll try this a bit more


#4

I am having the same issue as described in the original post. Has this been resolved? if so, any assistance would be appreciated. I am relatively new to Particle and have set up 3 Borons (LTE) in the past using only the iOS app.
Thanks !


#5

@tonym after debugging with @marekparticle the Boron devices I got we think are defective. I got new Boron devices from particle as a replacement and they worked fine. Note that some Boron devices did take a day or 2 to come online, this also might be due to SIM activation que on the service provider’s side.

If you are having connectivity issues, I suggest running the cloud debug binary, gather some logs and then perhaps ping support with the logs to see what they can do. Particle support can also tell you if there is a SIM activation que.


#6

@slacker89 thanks for the reply and suggestions. I will dig into the cloud debug binary and reach out to support.


#7

Awesome, @tonym!


#8

I was able to get both new Boron boards to connect and complete the claim process. One did on its own and the other required the claim process via the app. In the end, I did not do anything special. Thanks @slacker89 @marekparticle


#9

I think @slacker89 nailed this one! :slight_smile: