Boron cant connect to 2G / 3G

Fresh out of the box, connected with the particle app, got to activate sim, did that, got to update device, device updated, got to connecting to network, error, try again, try again, try again, but nothing.

Device is flashing green. Here’s a screenshot of the error:

Update: Looking at the sim slot, and I dont see a sim card in there? What gives?

The Boron uses an embedded SIM for the Particle connection. The SIM card holde is for 3rd party SIMs.

It may take some time for the service provider to really activate the SIM for you even when it’s already activated as is concerns Particle - especially when it’s going across the big pond :wink:

The Boron 2G/3G uses a different carriers than the Electron in what I believe to be your country. You should check this table and make sure you have coverage from the carrier listed for the Boron 2G/3G.

Your SIM card appears to be activated correctly.

1 Like

Ok, leaving it over night to see if things change.

It’s been running for a few hours now, still green light. The list shows one operator being supported for my country.

I reactivated my electron, and it works now, after I left it for 30 minutes.

Will reply tomorrow morning with the latest updates.

Hi, same problem everytime with my Boron 2G/3G (last 3 Boron). I have make several test like particle update CLI and i can’t confirm how to, but it’s work after a couple try. Right now on my bench table, a brand new Boron 2G/3G ready to install tomorrow and I’m stuck with led green

@r0b0tn1k I’ll probably save your time, please follow this instructions, I just want able to connect my Boron. The first time you activated your Boron, you probably see the screen to start update firmware on your Boron, let him update firmware. Be sure your internal SIM it’s activated before do the steps.

  1. Using Visual Studio Code, log into your Particle account and make sure your have the latest CLI up to date
  2. Visit this page and download the firmware “hybrid-0.9.0-boron.bin”, save it where you want on your computer ex: my it’s Downloads
  3. Connect your Boron with USB + Battery to the USB port
  4. Put your Boron in DFU mode
  5. Go to you folder where you saved “hybrid-0.9.0-boron.bin” firmware and run this command : particle flash --usb hybrid-0.9.0-boron.bin
  6. When is flashed, you will feel scared to see that the Boron LED blinking Red, don’t panic, put back your Boron in DFU mode
  7. Run this command : particle update

Your Boron will reboot and max 2 minutes, you will see the LED breathing as normal. Please let me know if it’s work for you

Hey, just an update:
Device ran all night, it did not connect to network.

Followed @steeves instructions, device rebooted and started flashing blue.
Re-enrolled and re-activated SIM.
Trying to connect to 3G network, and at first try it failed.
It fails on the same “Connecting to the internet via cellular” option.

You can try the Boron cloud debug firmware and get a carrier scan log as well as a normal connection attempt. This will determine what’s actually failing.

I installed the 0.9 firmware, and after the reset it it keeps flashing red?!?

Oh, and @rickkas7 if I try serial monitor it says serial port identified? Guess it has to do with the boron flashing red?

Look my post. Just plug in DFU mode and run CLI command : particle update

@steeves Sorry I wasnt clear. Your instructions worked great, but after an hour or two it still was not connecting.

Hey @ScruffR, just wanted to confirm what my next steps should be?
Should I ask for a refund for the device and return it, or is there any action I can try?

I’d defer to @rickkas7 or you could file a support ticket at

Going on vacation, I’ll raise a support ticket as soon as I’m back, as I have an LTE Boron as well, and I havent even tried to power that up.

Today trying again another Borin 2G/3G and it’s again the same problem, I’m stuck in a green flashing led. For the previous Boron I made some recipe when trying to use the boron cloud debug, reflashed to the 0.9.0, use particle update and I can’t understand why it’s working without know the reason.

Today it’s my fifth and I’m stuck in the green light flashing. Btw I am at the same place when my others Boron 2G/3G work. I really need to figure out the problem. thanks

I am having trouble as well.

I scanned the code, plugged in to the antenna, battery and USB cable, downloaded the updates and the setup gets as far as trying to connect to the Particle Cloud, where it just gets stuck flashing green for hours on end.

Any fixes?