Boron 2G/3G can't connect to Cloud even if internal SIM is activated

Hi folks

I use another Boron 2g/3g in Canada since 1 month with no issues but was the same problem to cloud connect like my new Biron. I can’t remember what I done to fix it. Actually I have problem to connect to particle cloud (green led blnking) with a second Boron 2g/3g. The SIM is activated in the Console Particle but not able to connect to Particle Cloud. I have also tried to flash the firmware 0.9.0. and it’s not work. I have tested with 2 differents antennas, no luck. For your information I don’t use third SIM.

I have sent a request to support but while waiting anyone can refer too a similar post as my problem to try to self troubleshooting?


1 Like

Anyone welcome to help, because I can’t figure out the problem.

I haven’t used a boron yet - however when I got similar issues on my Argon and Xenons, I ran

particle update

From the command line with the device connected over usb to my PC - that seemed to restore most things back to normal - not sure how it would work in the case of a Boron, but worth a try if you haven’t already tried this.