Problem connecting to dual-band router with same SSID


#1

I’m failing to setup up a particle photon connected by USB to a mac with OS X Sierra. The wifi I’m using (SSID CalVisitor) has no password.

  1. web setup (Chrome) in Step 2 keeps displaying “Please fill in all the fields” - well, I filled in the CalVisitor. Tried both leaving the password empty (as it should be) or typing in some random string still gets me the same “Please fill in all the fields”.

  2. cli: everything works fine (photon finds CalVisitor, among many other nets) and detects correctly that it has no password. But then it gets stuck with “It doesn’t look like your Photon has made it to the cloud yet.”

One possible issue is that CalVisitor is both on 5G and 2.4G, same SSID. But I assume that if the photon cannot connect to a 5G network, it will simply not display that SSID?

Oh, and the CalVisitor net works just fine. I am now connected through that net!

(I already perused the web and this forum to find possible workarounds. I’ve flashed the firmware. Not of that stuff helps.)


#2

This is definitely causing an issue for the Photon.


#3

Going to change title of this thread to “Problems connecting to dual-band router with same SSID”


#4

Can you elaborate?
Again, if the photon radio operates only in the 2.4GHz band, one would expect that it simply does not “see” networks at 5GHz?

A bit more trying since:

  1. Setting up the connection with a smartphone gets through connecting to the network but then gets stuck in what I remember was the 5th step, verifying something. So at least based on that error message, the network does not seem to be the problem.
  2. I tried again at home (network protected with password) and the setup worked without hiccup. Again used the phone this time.

Are there other options to diagnose the problem? Again, the messages from the phone setup at least do not point to a network problem.


#5

@ttmetro, the issue may be with the router, favouring traffinc on the 5GHz side. The Photon may be getting “pushed” there. There may be a setting on your router to change that. Otherwise, you may need to change one of the SSIDs so the Photon can see the 2.4GHz connection uniquely.


#6

This “router” (actually hundreds of access points) is infrastructure of the University of California, Berkeley. It’s not trivial to make a little change to the configuration. And setting up with identical SSIDs is recommended practice, so I won’t get very far trying to convince admins to change.

I am still puzzled that

  1. When attempting to connect with the i-phone, it says it connected to the wifi and gets hung up only later at the verify step. Unless the feedback is incorrect (shouldn’t that be fixed then, rather than changing router configurations?) the photon is actually connecting to the WLAN. For some reason it needs to do some “verification” after connecting - what exactly is this? Where can I learn more about it to hopefully understand why it gets stuck?

  2. Unless this has changed, the Photon (BCM43362A2) does not support 5GHz (e.g. it has only one antenna). So why would it even see the SSID sent out by the 5GHz access point? What am I misunderstanding that this cannot possibly be the issue?

Thanks for you support!


#7

@ttmetro, you hadn’t mentioned the University network before. This is most likely an Enterprise network where you need to enter network credentials, not a wifi password. In that case you will need to take a look at the regarding how firmware version 0.7.0.rc-3 can be setup to connect to an enterprise network:


#8

No. There is no password.

But I did learn there is a firewall, and that’s likely causing the problem.

I believe the network is just fine and the 5GHz is not the issue. The error messages from the photon setup could be a bit better. I still have to verify this.


#9

Do you have any suggestions? I think the error message that the Photon did not made it to the : cloud: as well as you having a blinking cyan followed by few red blinks means no internet connectivity, fits what you observed.

The CLI is unable to tell if you are using a login with registration required or has a firewall that doesn’t allow the CoAP connection.

Also, if you see blinking green, it means you did not managed to connect to the WiFi network.


#10

The cli interface simply says the Photon was not yet able to connect to the cloud.

The iPhone interface gives a bit more information (5 steps, if I remember correctly). From that information I was able to conclude that the device probably connected to the internet, but then got stuck in some registration process. That in turn tipped the IT folks off to suspect this to be a firewall problem (which it was).

Perhaps the CLI could give the same information as the iPhone app. Especially since I at least usually assume that the command line tools give maximum detail and usually go there when I have a problem. It’s just by chance that I gave the iPhone even a try and may still be wondering what’s going on if I had not.