Photon WiFi at customer site - successful provision, but never moves past flashing green

Hi there, to date I’ve helped a handful of customers remotely get my Photon-based product connected to their wifi network mostly without issue. Today is the first time I’ve hit a wall - we were able to use the iOS app + skip authentication to connect and it succeeded quickly. However, Photon remained flashing green (never flashed more quickly like it was nearing a successful connection).

We then cleared WiFi credentials and tried again using SoftAP and ran into the same issue - flashing green without a successful connection ever being made. I am running firmware 2.0.0-rc.2 and have other units with identical firmware and code working fine at customer sites.

Customer has an Arris CM820 router which creates both 2.4 and 5ghz networks and we also tried directly next to the router. Any idea what might be happening or what else to try? Customer is non-technical so using CLI is not an option. Do I need to jump into the router settings to enforce 40mhz width?

My back up idea at this point is to ship an Argon-based unit instead with the customer’s credentials pre-loaded, but also worried in case that fails. Any help is appreciated, thanks!

@policenauts, the Photon will only connect to the 2.4GHz network but if the 5GHz channel shares the same SSID, then it is likely that the router is “forcing” the connection to the 5GHz band, which won’t work. Another possibility is that the customer’s router is blocking the COAP port used by the DeviceOS to connect to the Cloud. Take a look here:

@peekay123 Thanks! I believe the 2.4 and 5GHz are two separate SSIDs so I don’t think that is the issue, but I will confirm.

In terms of CoAP, would I need to have the customer manually allow-list of those IP addresses? Or if it’s a mac address issue, there any way to access this particular Photon’s mac address if it’s not currently connected to the cloud?

@policenauts, you customer could whitelist the mac address but should also check that the COAP port is open. The is a programmatic way to get the mac address but that would require a serial terminal (PC) and a change of code.

One way to test without the router is to use a mobile phone to create a wifi hotspot and another phone to reconfigure the Photon to use that hotspot. If the Photon connects to the cloud then you know it’s a router issue. I couldn’t find any documentation on configuring the Arris CM820 router so hopefully the customer has someone capable of doing that.

1 Like

According to this discussion here the Photon may have issues with 40MHz wide-bands offering that option may even have the effect that the connection is silently dropped (provided it was ever established :wink: )

Thanks @ScruffR, I mistyped and meant 20MHz!

@peekay123 as it is flashing green, doesn’t this mean that the wifi connection cannot be made and hence the outbound port block theory is not relevant ?

@policenauts suggest the following. Get the customer to set up a hotspot on their mobile phone using the same SSID and credentials as their Access Point. (Turn off the Access Point) Can they now connect?

Secondly, you said

I believe the 2.4 and 5GHz are two separate SSIDs so I don’t think that is the issue, but I will confirm.

Did you confirm this? I ask because this is an issue…

@UMD thanks for the tip and sorry I never circled back on this - in this case, this customer was extremely non-technical and in the end I shipped them a non-Particle based workaround. Out of curiosity, what does setting up the hotspot with the same SSID and credentials as the AP do? What does it suggest if it works (or still fails)?

I wasn’t able to see it with my own eyes, but I confirmed with the customer multiple times that the 2.4 and 5GHz had their own SSIDs so I took them at their word.

@policenauts so there goes the theory of 2.4 vs 5 GHZ…

Re the mobile hotspot, being able to connect means that

  • There is no issue with your hardware (eg bad antenna)
  • There is no issue with your firmware
  • The SSID and password supplied by the end user is correct

Not being able to connect points to:

  • Issue(s) with your hardware
  • Issue(s) with your firmware
  • The SSID and password supplied by the end user is incorrect

What is their WiFi channel bandwidth set to? If needs to be 20 MHz, not 40 MHz.

@UMD thank you Harry.

In the end I wasn’t able to check their WiFi channel bandwidth. I had always thought in theory I could help a customer adjust their router settings, but in practice, the act of asking a busy customer to download Zoom desktop (so that I could remote in) and then jump into their WiFi settings (where I could potentially break something) without any guarantee of success proved too risky to attempt, at least in this case.

Hi @policenauts,

Some time ago I had a customer enter their particle account password instead of their wifi password.

We were on the phone troubleshooting this when I asked them to enter their wifi password and something clicked on their side and then realized their error.

Cheers!

@policenauts, @gusgonnet believe me, I know what you mean!

@policenauts you could ask your client to download a good WiFi scanner mobile app and get them to read out the details. I know that you have provided a work around, but it would be a good idea to understand this problem for next time…

1 Like

@UMD thank you, that’s a great suggestion for next time. I just downloaded one for my Android device, outside of confirming presence of 2.4GHz network and 20mhz channel width, is there anything else I should be checking for?

Check if the customer’s Access Point has a 5GHz channel as well, and if so, has it the **same SSID ** as the 2.4 GHz channel. If so, this is a problem.

I believe that you have checked this, but it doesn’t hurt to reconfirm…

Access control and DHCP pool may also interfere here.
If the customer has activated MAC Address filtering but forgot to white list the device or the pool of available DHCP addresses on the router has been used up (or DHCP is disabled completely) the device will be unable to connect.

Alternatively if the device ever was setup to use static IP you’d need to actively tell it to go back to dynamic IP.

To acquire specific information why a Particle device won’t connect it would also be helpful to run this and investigate the log.
I’d also add a SerialLogHandler logHandler(LOG_LEVEL_ALL) to get any info from the system it is willing to provide.