Changing Wi-Fi credentials

I’m trying to change the Wi-Fi network for a device and it fails repeatedly with no information I can use to troubleshoot the issue. I have a Particle Photon device working perfectly on my home network. I want to install the device on a different network, so I put the device in pairing mode (blue blinkie light) then opened up the Particle app on my phone to start the pairing process. I select the device, pick the Wi-Fi network, then provide the password and the app spins for a while before reporting that it couldn’t complete the process.

I’ve tried this many times with the same results, every tried it in several areas of the building (to get a better Wi-Fi connection).

What can I do to determine what the issue is? I Can’t try to resolve it until I know what it is. I know my smartphone is on the network with the correct Wi-Fi settings.

Is this a 5GHz WiFi? The Photon wouldn’t be able to connect to that - even when your phone can :wink:
Also Captive Portals are a no-go.

3 Likes

aaah, yes, that’s probably it. Let me check. Thanks

Hi John,
If the Photon is able to see the WiFi network, then it may not be a 5Ghz wifi network (since the Photon can only see 2.4Ghz networks). However, if 5Ghz and 2.4 Ghz SSIDs have the same name, perhaps that could cause trouble?
Gustavo.

Some AP’s will do band steering and if they have the same ssid then you will have issues.

Could also be the WiFi channel width. What is it currently? If it is 40 MHz, reduce it to 20 MHz.