Photon/P1 cannot connect to dualband network

Does photon/p1 now have methods to connect to dual band (2.4Ghz and 5Ghz) network that uses the same SSID and password? Such as it’s able to identify itself to the router do not connect to 5Ghz? or some workarounds without the need to split the 2.4Ghz and 5Ghz wifi network with 2 separate SSIDs

The WiFi Radio on the Photon (BCM43362) doesn’t support 5GHz.

Understand photon doesn’t support 5Ghz. The issue is I want to connect to the 2.4Ghz network but when 2.4Ghz/5Ghz network transmitted by a router uses the same SSID and password, photon has issue connecting to the network.

I understand now. Is the SSID being broadcast by the same router on 2.4 and 5GHz? Typically in these cases I have seen different SSIDs used for each network.

Understand photon doesn’t support 5Ghz. The issue is I want to connect to the 2.4Ghz network but when 2.4Ghz/5Ghz network transmitted by a router uses the same SSID and password, photon has issue connecting to the network.

I have seen this problem on a customer site where they have a 5GHz and a 2.4GHz networks using the same SSID and the Photons then can’t connect to the 2.4GHz network. As @picsil has suggested the work around is to call the 5GHz WAP something different.

If you see issues with a combined 2.4GHz and 5GHz SSID it’s usually related to the WiFi AP and not the Photon/P1.
Some APs insist in attempting to move a valid 2.4GHz connection into the 5GHz band irrespective of the devices capabilities - which is bound to cause issues.

But it’s not something that will cause troubles in all cases. In my personal experience I can vouch for Netgear Orbi WiFi Mesh routers to handle this situation just fine - even with roaming devices between individual “satellite” areas.

2 Likes

But for other devices such as an older generation iphone that can only communicate on 2.4Ghz wifi, how do they make sure that their device does NOT get moved by the router to 5Ghz network?

Is there something similar that can be implemented in the code for Photon/P1?

Thanks

The Photon/P1 use the Cypress software library called WICED. This commonly used but closed source has proved to have had a number of issues - it may be that the behaviour you are describing is a known issue. That will no doubt be the problem with implementing a solution for these Particle devices.

2 Likes

So that is a known issue that will be fixed soon? Now days routers are trending towards having dual band transmission so it’s an issue that will be experienced by more and more users.

Thanks

1 Like

@roger_mary, I don’t believe there will ever be a fix for this, especially since changing the SSID of one channel on the WAP fixes things.

From a business perspective this is not a solution in the slightest. Asking a customer to make changes to their network to accommodate you product almost never goes well.

I’ve used Photons for several years on networks that are dual-band using the same SSID for both bands. I agree with ScruffR that this is probably something with the Wi-Fi configuration trying to steer clients toward 5 GHz. WiFi is a protocol where the client makes all the decisions. Sometimes those decisions aren’t the best ones so many WiFi hardware vendors try to trick the client into making the decision that they think is best. If the management software thinks a client is dual-band capable and tries to force it to 5 GHz when it can’t support it, that would cause issues.

I current have Photons on Ubiquiti UniFi and Cisco Meraki dual-band WiFi with no issues.

1 Like

Also though, I would think that if the network config is the issue, you would see issues with a lot of other devices, too. Unless, that is, only a very specific set of devices are currently using WiFi.

I agree. It would be great if the particle team can figure out a solution that tells the router client that Photon does not support 5Ghz. It is not practical for customers to change their SSID just for this device + not everyone is technical enough to know how to change the router network settings.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.