Photon unable to connect to hidden SSID

I am unable to connect my Photons to a hidden SSID that has no security. I have tried with the iOS app and I have also tried with the particle serial wifi command. The serial command indicates that it communicated with the Photon but then reports back that the command timed out and suggests restarting the Photon. Restarting simply generates flashing green and never connects. Any suggestions would be appreciated. Is it possible that current firmware can’t handle connecting to a hidden SSID?

I am deploying several Photons at a public elementary school as part of various science projects. I do not have direct control over the wireless setup and the entire school uses either wired connections or hidden SSID without any passwords for internet access. BTW, the Photons will be solar powered and located outdoors.

See this fix here:

Thank you for the link. Unfortunately, using the iOS Particle app does not work. The link suggested it did but the person also previously connected to the same network when it wasn’t hidden. See the Oops! screen below that pops up when you try to connect to a hidden SSID with no password. I see that a fix is in the works when using the CLI but it would be nice if it was also fixed in the Particle iOS app since this is a more common method for setting up Wifi (especially if they are customers for a product based on the Photon).

UPDATE: So upon restarting the Photon it made a WiFi connection and started breathing Cyan. I wasn’t sure if the Photon was connected to the hidden network or the normal password protected network I have used with this Photon in the past. So I turned of the hidden SSID router and after a minute or so the Photon started blinking green. I turned the hidden SSID router back on-still blinking green, then I restarted the Photon and it connected. So apparently using the the iOS app works but it is glitchy.