Photon wont connect to A2 security on new iphone xs. Ideas?


#1

I have 2 wifi Photon OBD2 dongles that send CAN data to an IP address that I can check on my phone or tablet. Previously both Photons would connect to the wifi hotspot on my verizon cell phone. I had an iphone 6. It worked well.

I finally upgraded and got a new iphone xs. I tried to connect the two Photons and they wont connect to the new wifi of the iphone xs. I took my sim card out of my phone and plugged into my verizon ready ipad (its not currently activated with its own service), went through the set up process, and the Photons connected no problem.

So it definitely has something to do with the new A2 security in the new iphone xs. Any ideas? I could sign up the ipad with its own Verizon service but thats another $20 a month! Id prefer not to spend that when I already have it on the iphone.


#2

Note: the Photon OBD2 dongles are not just dongles.
These are Carloop devices. See Carloop.io for more detail.

One thing as mentioned on the Carloop forum is to setup WiFi credentials on the Photon so it can connect to the WiFi hotspot of your new phone.
Make sure you do not clear the credentials on the Photon for your computer, tablet, etc. so you do not have to set those up all over again.

There are other suggestions to your post here:

Let us know how that works or if you have other details.
Maybe we can help you figure it out.
Good luck!


#3

We have tried everything you have suggested before you suggested it. It seems to be an issue with the new A2 security from apple on the new IPhone xs.

If you are really interested in helping it would help if you didnt respond on all threads separately, refer to your own posts in another, and then link them all together. It makes things really confusing.

If you have any A2 security experience please let us know.


#4

I am certain there are a few mobile phone app developers on this forum (beside the ones that work for Particle).
To get them interested, can you provide some more information?
Which method did you try to add the WiFi credentials to your Photon so it could connect to your iPhone?
Was it the Paricle app, the CLI or the online page (I think it is setup.particle.io)?
What specifically happened? Were there any error messages?


#5

With the help of someone else, we used a terminal window on my Macbook.
We asked Particle to show us the wifi signals. We tried connecting it to my house, WPA, and it worked. We connected it to my ipad, WPA, and it worked. But when we try to connect it to my Iphone xs, A2, it wont connect to the internet.

No error messages, the unit just continually blinks green saying its not connected.


#6

Not sure if this is related to this post:

There was supposedly a fix put in for the above issue. Perhaps ping @Raimis for clarification.


#7

Hey @jimbo69ny, sorry to hear you are having troubles. Can you please provide more details on what actions do you do and what fails in particular. Like a step by step process. For example:

  1. I’m using particle ios app or custom built app
  2. I don’t see wifi networks at all or I see them, but after choosing one it fails to connect.
    etc.

As @ninjatill mentioned, there was a fix for particle app regarding wifi setup. And that was the only wifi related issue known to me.


#8

With the help of someone else, we used a terminal window on my Macbook.
We asked Particle to show us the wifi signals. We tried connecting it to my house, WPA, and it worked. We connected it to my ipad, WPA, and it worked. But when we try to connect it to my Iphone xs, A2, it wont connect to the internet. The terminal shows all of the wifi signals but strangely it does list my phones hot spot as “James’s iPhone 3a”. We dont know why it adds the “3a”. The name of my phone and hot spot is simply, “James’s iPhone”.

No error messages, the unit just continually blinks green saying its not connected.

I have not tried the app although I will try it shortly.


#9

No luck. It wont connect to the app. The app shows my two devices but there are no options or buttons to connect them.

So I tried to add one of them as a new device. I followed the steps and then received an error message that said
"Setup process couldnt configure the Wi-Fi credentials for your Particle device, please try running setup again after resetting your particle device and putting it back in blinking blue listen mode if needed."


#10

Can you get other devices to connect to that hotspot? I see many topics on the internet where people are having problems with their hotspots hosted by iphone xs or xs max. I have reported this thread to carloop engineer. I really can’t help much here, because the problems you are facing (from what I understand) are either problems with the photon used in carloop or the hotspot itself.


#11

My hot spot works perfectly. I use it all the time for many different devices.


#12

Any other ideas?


#13

Based on the things you tried so far @jimbo69ny your Photon can:

  • Connect to your home Wi-Fi
  • Connect to your iPad Wi-Fi hotspot
  • But not connect to your iPhone XS Wi-Fi hotspot

The Photon is only able to connect to 2.4 GHz Wi-Fi networks. Most home Wi-Fi routers use the 2.4 GHz for Wi-Fi. Some newer ones use 2.4 GHz and 5 GHz. Previous generation phone/table Wi-Fi hotspots all used 2.4 GHz.

My best guess is that Apple decided to change the iPhone XS Wi-Fi hotspot to use the 5 GHz frequency exclusively so it is no longer compatible with the Photon. I could not find specifications for the iPhone XS to show this is the case, but this thread on the Verizon forum seems to indicate other people are having similar issues.

https://community.verizonwireless.com/thread/956366


#14

Thank you for the info. Is there a way to test the frequency of my iphone xs hotspot?


#15

I found a way to test my hot spot connection. I connected my Mac to it. It all looks pretty normal actually. Back to the drawing board.


#16

On another device that has 5GHz capability, download a WiFi network scanner and scan for available networks while the iPhone XS is in hotspot mode. I have only ever use WiFi network scanners on devices only capable of 2.4GHz so I’ll have to leave it to you to find the appropriate network scanner app in whatever app store is available on the device.


#17

That shows what the mac is currently connected to, not all the networks available on the various frequencies and channels. The network scanner I describe above would show you all that. Just an example for the one on my Adroid phone:


#18

@jimbo69ny, would it be too much to ask you to have quick video of you trying to setup photon to work with the carloop device? By looking at the video we could verify if there are no errors in steps you are taking and possibly give more insights in what is happening. I will go to nearest apple store later today to see if iphone xs hosts 5ghz hotspots (until now i didn’t see any reason to ask company to get me iphone xs for development purposes).


#19

Ask me any specifics you need to know. I think I have described my process a couple times. I dont receive any error messages. If you must have it I could make it.

I posted above about the Hot spot connection. Please read it. It is NOT 5ghz and security is normal.


#20

It appears that your phone hotspot is 802.11n. This should normally be fine, except there’s an unrelated bug that prevents Photons and P1s from connected to an 802.11n-only Wi-Fi network, which is what you have. This bug is in 0.7.0 and 0.8.0-rc versions.

The best workaround at this time is to downgrade your device to 0.6.3.

  • First install Tinker so you don’t get upgraded back immediately. Put the Photon in DFU mode (blinking yellow) by pressing RESET and SETUP at the same time, releasing RESET and continuing to hold down SETUP while the LED blinks magenta (red and blue at the same time) until it blinks yellow, then release.
particle flash --usb tinker
  • Go to the 0.6.3 release site and download system-part1-0.6.3-photon.bin and system-part2-0.6.3-photon.bin.

  • Flash these by USB in DFU mode (blinking yellow):

particle flash --usb system-part1-0.6.3-photon.bin
particle flash --usb system-part2-0.6.3-photon.bin
  • When you compile firmware for your device, click on the Device icon (circle with 4 lines), then > and make sure the target system version is 0.6.3. If you don’t do this, the system firmware will be upgraded again and the problem will come back.