iOS 10 rejects a Photon in setup


#1

I simply want to register my Photon, but it won’t let me.

When the Photon broadcasts it’s WiFi, I connect with my iPhone.
Normally, I could go back to the app, wait for a few seconds and the setup would begin.
But not now. There’s a short connection, and then for some reason it disconnects.

What I think is happening is that iOS rejects the device because it is unsecured and does not broadcast any internet connection. It’s probably not something wrong with the Photon or the Particle app for that matter, but I think it is noteworthy.

If someone knows a solution, i.e. preventing iOS from doing this behavior, then I’d like to know :slight_smile:

EDIT: it seems my iPhone was unable to, but someone else’s iPhone instantly connected without problems (also on iOS10). So I don’t really know what’s wrong, I reclaimed my device so all is well at the moment :slight_smile:


#2

Checking…


#3

Phew! That would have been bad…


#4

@Len Glad you were able to reclaim your device! Let us know if you have any more issues with the new update in place.


#5

Hi @Len, This is happening with my iPhone now that I’ve upgraded it to iOS 10. My iPhone has several ‘Security Recommendations’ and won’t post the Wifi logo to the top information bar. I have tons of devices, and it would be good to know whether they’ll be able to get past it. It appears to connect for just a second, and then the iPhone terminates the connection reporting ‘No Internet Connection’ and has ‘Security Recommendations’. How do I turn these off or bypass them?


Photon SoftAP mode - mobile cannot obtain address
Using Photons at remote locations: How to connect WiFi without me being there
Official Particle Android app is unable to see new Photon's
#6

I’m not sure why that would happen. After I select the Photon Wi-Fi network iOS does display “Security Recommendation,” because the Wi-Fi network itself is not encrypted. I didn’t get a warning about no internet connection, but that would be expected as the Photon setup Wi-Fi is isolated from the Internet. All I had to do was tap the notification at the top of the screen and setup proceeded normally. Just tested with iOS 10.0.2. Very strange.


#7

@rickkas7, Spot on, mine does the same thing, but then in the particle app it spins the spirally thing inside the line item for the Photon-XXXX and just continues to do that over & over again without resolving it. The iPhone itself has ‘No Internet Connection’ under the Photon when in the past it had a check-mark like yours does.

I’ve setup 150+ Photons using the same method. And post iOS 10 update this is a new issue. Sorry! But could use some new ideas… :smile:


#8

Because I had someone else doing the setup, I didn’t trouble shoot it. The next time (a few days later or so) I could use my iPhone again. As far as I know I only rebooted my iPhone. Now it works on iOS 10.


#9

We’ve got a customer reporting this behavior as well in iOS 10.0.2 on iPhone7

At first, the iOS wifi contextual information displays “Security Recommendation” and then quickly updates to “No Internet Connection”. Also with a spinny icon and no check mark.

Selecting the network and then returning to our app (running particle setup SDK) displays the behavior @ghovagim reports - spinning with no resolution. Eventually it times out and we display an error screen.

Going to try on another phone, and try a reboot.


#10

Mysterious. I originally tested with 10.0.2 on an iPhone 7 Plus and it worked fine. I just tested again with 10.0.2 on an iPhone 6 Plus and it also worked fine. I’m not seeing the pattern to the failures yet…


iOS 10 and SoftAP
#11

I am unable to reproduce this issue locally on iOS 10 or find info about it.
Is there any specific iOS setting that enables the “no internet connection” label behaviour?


#12

@ghovagim, @dan or @BCN, could you help @ido reproducing your issue with iOS 10?


#13

Hi ScruffR — I have no problems connecting to a Photon-XXX wifi connection in iOS 10. The problem I described is SoftAP setup on a iOS 10 device.

https://community.particle.io/t/ios-10-and-softap?source_topic_id=25864

#14

Yup, but the underlaying problem might be the same as the your mobile browser or own app and the Particle app connect to the same “interface” on the Photon the same way.
The only difference is the data handed back to your device after the connection got established (AFAIK).

But the input provided in your own thread might help getting to the root of the underlying problem.


#15

This is exactly how it happened on my phone, when I had the problem.

Maybe an other (running) application on the phone is trying to access the internet and because of this the “No Internet Connection” error is shown? I haven’t set up any Photons since, but will again soon so I’ll try that one out.


#16

I have the same issue ghovagim described. SoftAP on the photon device. The iOS device does not establish a WiFi connection. The Photon is flagged with an exclamation point on the device in the WiFi list and displays a warning. I switched over to a Windows 10 PC and it instantly connected and allowed access to the softAP screen. This appears to be something specific to iOS.


#17

@rickas7, you said “it also worked fine”, but refer to the following ticket:

Am wondering if your hardware setup (eg perhaps a stand-alone Photon or on a bread board) is different to @Len and @ghovagim because that it what I and others are finding…

To prove a point, can @Len and/or @ghovagim repeat their experiment on a stand-alone Photon?


#18

Interesting idea. Clearly there’s something different between how Ido and I have been testing this where it works without problems and the situation where setup fails with iOS 10. I sort of assumed it was some iOS setting that’s different with some devices, but it certainly could be something else entirely!

I’ve been testing with Photons in small breadboards, powered by USB.


#19

@Rickkas7, you have added weight to the theory. We just need @Len and/or @ghovagim confirm from their end.

I have absolutely no doubt that there is a hardware issue because I have the problem with two different PCB’s.

Note that I don’t even need to solder the board - just sitting the Photon atop of the PCB with a strips of cellotape as a layer to stop any electrical contact reproduces the fault…

Could well be earth loops or something like that.


#20

This has been a while ago, but as far as I remember, I only had the Photon connected to USB. No PCB (although we’re currently using them with a PCB). It was also solely rejected by my phone alone, because a colleague of mine tried with his phone which was running the same firmware version and it worked for him.

My theory is that the background applications of the iPhone are trying to use the WiFi to connect to the internet, and as such the Settings detect there’s no internet and keep trying to reconnect making it impossible for the Particle app to get to the point where it can configure the Photon.