Photon couldn't find AP

Today I redeployed a Photon I’d had offline since the end of March. It was reconnecting to the same WiFi AP as before. Same hardware, unchanged SSID, unchanged key.
Just constant flashing green LED.
So I put it into listening mode and tried to connect it using the Particle app.
I was able to connect to the Photon and get it to show nearby APs.
It showed all of them apart from the AP it used to connect to.
However I know the AP was available and working because I was using it on my iPhone.
I was able to access the wider internet through that AP from my phone.

So then I tried to manually configure the AP - no dice.

Any ideas what was going on? It’s still going on, but I just got so disheartened I gave up for the day.

Thanks

That doesn’t mean a lot - your iPhone could be using the 5GHz band while the Photon only supports the 2.4GHz band.

Also, could it be that the Photon was set to use a static IP that wasn’t available at that time (i.e. occupied by another devices)?

Have you tried Safe Mode?

Thanks Scruff. I guess I could check (and I will) if the 2.4ghz network my Photon used to connect to has somehow changed into a 5ghz network.

I hadn’t considered safe mode because of this:

If you have something that’s preventing Wi-Fi access, such a Wi-Fi access point problem or a configuration problem, safe mode won’t help. It’s not designed for that; it’s designed to allow OTA flashing.

But I’ll definitely look into the 2.4/5 ghz question!
thanks

In that case it’s true, but as we cannot be entirely sure that is the case, I wouldn’t conclude there is no point in trying :wink:

BTW, you can use particle wifi and then answer all questions about auto scanning with N and enter the SSID manually.
This works best when the device has no WiFi creds stored at all.

Hi Scruff - thank you for your help - I’m still unclear as to how safe mode would help when the device isn’t able to connect to wifi - isn’t that needed for safe mode to even have a hope of working?

I’m beginning to think there’s something really odd going on with this Photon - I’ve checked and the WiFi network is 2.4ghz and it shows up on my phone and many other devices and I can use it from a laptop etc.

When I put the Photon in listening mode (blinking blue?) and then try to go through the app claiming procedure (setting up a new Photon) the WiFi network just really stubbornly refuses to show up. Can I query where the list of available SSIDs that shows up on the phone is coming from? Is it the phone or the Photon? I manually input the SSID and it auto detected the security, totally completed all the tickboxes but then said right at the end there had been an error. All the while the Photon was blinking green.

I have a funny feeling Particle doctor would help me here but unfortunately the USB port on this Photon is not very well so I can’t get a serial connection going to it.

Arrrrg! :slight_smile:

True for AUTOMATIC mode without SYSTEM_THREAD(ENABLED), but if this is not the case something in code may be causing the issue and Safe Mode would reveal that.
As I said, we don’t know anything about the code running, so we have to consider every possible cause.

And there is still this

And in addition, could it be that the device is set to use an external antenna but hasn’t got one attached?

OK I’ll give it a go :+1:

Nope - definitely not setup to use a static that’s unavailable but I see why you ask

Definitely no external antenna

I will try safe mode then if not, do you think the Embedded SWD route would be my next best step?

I wouldn’t see how that would help.
This is mainly meant to cure the Dim D7 LED issue but won’t do anything to cure WiFi issues.

I’d rather try the following

  1. clear all WiFi creds by holding SETUP 10+ seconds (till flashing rapid blue)
  2. test with another WiFi network
  3. particle update -v in DFU Mode
  4. flash an application that forces the device to use dynamic IP and internal antenna (just to ensure the expected state)

BTW, how many devices share the network in question?
Could it be that there are no free DHCP IPs left?
Is the AP broadcasting its SSID?
Are there any “funny” characters in the SSID or PWD?

d’oh!! This fixed it. Thank you Scruff. It must have got itself into a proper muddle somehow because as soon as I cleared the creds it began behaving itself as normal. Thank goodness. THANK YOU as ever

1 Like

Glad to hear that worked.

That’s why I already mentioned it even earlier

:wink:

yep freely admit I dropped the ball here - I totally forgot about the option to clear wifi credentials in amongst all the myriad recovery options! Ooops…

1 Like