Cannot set up Photon from iOS 12/iPhone XS/Particle IoT v2.5

Hello everyone,

I’ve had Photon devices for a number of years and have always been impressed by how seamless the set up process is. That is–until today.

I’m trying to add a Photon to my account–connected to a Wifi network with internet, ple-- the + button, select Photon, hold SETUP button for 3 seconds until the dark blue light blinks, press Next, go to Settings-Wi-Fi, select Photon device.

Normally at this point I get a notification that I am connected to a Particle device, so I select that and it opens the App back up. Now it doesn’t do that, so I navigate back to the app myself, and wait–normally it would connect to the Photon and proceed, but now it doesn’t detect the device and just sits there.

I’ve tried multiple Photons with different firmware versions with no luck–has anyone else had this issue? Could it be something broke when updating the app to support Mesh networking? Or maybe it’s an iOS 12 or iPhone XS issue?

iOS 12, iPhone XS, Particle App v2.5

I was able to set up via particle-cli, so crisis averted for now :slight_smile:

1 Like

I posted a similar thread today as well. No answers yet, but maybe keep an eye there as well. Hopefully someone can help us. :slight_smile:

Are you using an iOS app you developed on your own? I just found a solution to my issue - see here.

Hello. I have provided this reply in the linked thread. Decided to post it here too in case anyone finds this thread through google :slight_smile:

Hello everyone. I maintain iOS app at Particle (and iOS libs). Sorry for such late reply. Lately we’ve been very busy with adding Mesh support and only today I was told about this thread (and issue). I can confirm that this entitlement fixes the issue and I will submit app with this fix for Apple review today. If all goes well it should be available for download within next 24-36 hours (that’s how long apple review & appstore index update takes).

Right now I have very limited time to read these forums (and not sure how long it will take for that to change) unless someone points me to exact thread that I should read. If you think that you have found a problem with our iOS apps/libs don’t hesitate to tag me here so that I receive notification (still not 100% sure that works for me) and become aware of the problem as early as possible. You can also always ping me at or create an issue in respective github repo (preferred method). I get notifications for github issues and most of them get some kind of feedback the same or next business day.

Thanks Raimis!

Quick fix for this issue great job!

I wish I would of waited to update to iOS 12 Apple forces update which I don’t like.

Everything is working great now with your new Particle app update, again Great Job!

1 Like