[Photon] "Verify device ownership" failed

Hi,

I have tried erasing the whole flash of Photon. I built the firmware-develop repository with PLATFORM=photon to obtain the bootloader firmware. I downloaded the system-part1, system-part2 and tinker firmware v0.4.3 for photon in the release page of the ‘firmware’ repository in github. Then I used JFlash to program the bootloader to the Photon via SWD interface, it works in USB DFU mode with yellow LED binking. Then I updated the system firmware using dfu-util according to the wiki page:


The system firmware also updated succesfully since the blue LED begin blinking and the Photon appeared as a soft AP. Then I open the Particle App on my phone to “setup a Photon”. Everything went smoothly until the step “Verify device ownership”.
Then I reset the Photon and it never appeared as a soft AP unless I kept holding the setup button for 10s after reset to erase the user profile.
Besides, I have deleted the Photon in my Particle account before I erasing the whole flash of Photon.
Can anyone tell me how to fix this? or is this a bug in the firmware or in App?

Is the device blinking blue?

@kennethlimcp After I updating system-part1 and system-part2 via DFU bootloader, the blue LED begin binking and the Photon appeared as a soft AP.

I’m having the same issue, but I was able to connect at first.

I connected fine, flashed a test app, ran fine, modified the code, tested and ran fine. I stepped outside to use it remotely and realized I needed a portable WiFi. After a bit of circular logic trying to connect to my phone’s hotspot using my phone’s app (boy that didn’t work! I then tried connecting with another phone with my hotspot active…) it stopped recognizing my ownership.

Why do I have to unclaim the device just to change wifi? And did I do that too many times? Is the failure on my device or remotely?

Note: it still passes wifi connection, but fails on owner verification.

I’m at an impasse!!

You don’t!

You could just have ignored the error message, since your device was already claimed and you knew that better than the app. So a mere reset should have done the trick. Unclaiming a device to immediately reclaim it to yourself does not cure anything!

1 Like

My choice is “Cancel” or “Change owner”. Cancel just cancels. “Change owner” continues with connecting. I choose my house wifi, same as last time, it connects, then fails at “verify owner.”

There is no other choice. I have to change owner.

I’m not using the app, but AFAIK the WiFi setup should have already happend at that point, so Cancel should be the way to go.

Note, it breathes green after the ownership fail – which is supposed to indicate failed wifi connection, but that part of the checklist succeeded, plus I’m connected to that wifi, so the wifi is not the problem.

I does not show up on the website, nor on the command line, nor in the app – there is no device claimed in any of those places.

Hence the comment that unclaiming doesn’t help anything.
But hooking up to the cloud (breathing cyan) is independent of the claiming status of the device.
Actually in order to (re)claim a device it has to be breathing cyan (or magenta when in Safe Mode) to receive the claim code from the cloud.

Maybe try putting your device into Safe Mode to see if maybe the firmware on the device is preventing a good cloud connection.

It is now in safe mode (breathing magenta.) Now the app can no longer see it. On the command line, it still can’t be seen. In the Linux VM there is still no /dev/ttyA*.

It was not in safe mode when I first connected to it in the app. I held down setup until it flashed blue. The app sees it when it’s flashing blue.

Here are the app’s error screens, btw: https://goo.gl/photos/GnZ4rpCCgUJXgiBMA

You can see that connecting works fine. So I doubt the connection is the issue. I believe it’s the ownership issue at the cloud level.

If I flash the firmware, does it “become a new device” and I can claim it fresh? Or is the serial number permanent? if so, then I really think it’s an issue on their end, not mine.

Once in Safe Mode you can reclaim your device via https://build.particle.io by use of the ADD NEW DEVICE button in the target drawer.

Or you can use CLI.

Or press’n’hold SETUP to enter Listening Mode from Safe Mode - after that the app should see it again.

BTW, disclosing the code you have running might have cut all that discussion a lot shorter (as seen in the parallel thread on Carloop forum).

That did it!! Awesome! Thanks! (Note: New Device was empty before, but Safe Mode changed that.)

It is still invisible to the app, VM, and Mac command line. :confounded: But at least I can flash from the build.particle.io site.

1 Like