Photon fails setup - verify device ownership

Switched on my photon the other day, after several months of not doing anything, to try out a new project.
Tried to run the ‘Blinking LED’ project first to make sure everything was still ok but I keep getting a red blinking LED.
After looking through the particle website for the problem, it seemed to suggest that the firmware needed updating. Someway along the line of updating the firmware, I must have removed my device.
When I tried to add the device, I am failing the ‘Verify device ownership’ part of the setup.
What’s the setup trying to do at this point and how can I correct this?

I have looked at some of the other post relating to this subject and it seems very confusing. Is there no clear and simple way to get my device working again?

Regards

That’s like asking the question: “Is there no simple way down into the valley?”, after you got deeply lost into the snowy woods and noone knows where you exactly are.
So, yes there definetly was a simple way before you went off the path at some point and in your endeavour to find the way back you might have just got further away.

To help the rescue team, a lost person needs to obey some rules

  • try to find a place of relative safety
  • don’t move from there unsolicited
  • provide a description of your current position as detailed as possible
  • try to not (not even subliminally) offend people who are prepared to help

So then:

  • relatively safe place
    Download and install the most recent version of CLI (currently 1.27.1)
    Update the Photon via DFU Mode and particle update and then acquire the necessary info for the description of your current state

  • stay in safe place
    Put your device into Safe Mode.

  • provide description
    Is your device able to enter Safe Mode and stay there?
    What system version does your device now report?
    What exactly was the red blink you saw before the whole thing happened?
    If you have more than that one device, can you see the others claimed to your account? (e.g. particle list)
    Have you logged out of and back into your account?
    Have you tried particle device add <deviceID>? What result?
    Have you tried to claim the device via Web IDE? What result?

3 Likes

I managed to claim my device. Not sure how I managed this as the 'particle device add failed. The IDE indicates that the target firmware is v0.6.3

Thanks anyway.
Regards

oops spoke too soon. tried a new project the next day, unfortunately the IDE reported my device offline!

maybe it is offline…
Is it located near a decent wifi signal?
Did you establish what the red blinking error was before?
What were you originally doing with your photon “several months” ago and why did you then need to claim it again?
Is your WiFi set to 20Mhz, 40Mhz or 20+40Mhz?
How about flashing Tinker to it over USB?

Yes it was offline, don’t know why it was offline. It had been working fine the previous day.
Yes.
No.
The ‘getting started projects’ such as Blinking Led…
Checking the Hub, its using the correct frequency band
Haven’t tried that.

Tried messing about with it to get it back on line.
Couldn’t keep in safe mode always wanted to switch to the green blinking led.

I had just about given up, when the device started flashing the led, don’t know what colours it was flicking between. (one of them maybe red or could have been magenta ). After a few minutes, the led changed to the cyan.
I don’t know what was going on but I was able to flash my current project and try it out - which worked. (using my Amazon Echo to switch on | off a led).

Regards